Disable _msearch for dashboard?


(Thomas Decaux) #1

ES 2.4 - Kibana 4

I am running Kibana for a quite big web site (30millions event per day), using Kibana to display some aggregations, but dashboard with 5 widgets crash all the time (the msearch query get elastic error, I think about not enough memory).

We are running 3 data nodes, 2 http nodes, with 15 Go RAM each, no problem to run aggregation one by one, but msearch not.

So, I am asking if it's possible to disable msearch stuff and have widget running the query separately ?

Thanks you,


(Tyler Smalley) #2

With a _msearch request your giving up a small amount of time in exchange for the compounding latency of multiple _search requests. In almost all scenarios this is preferred and there is not currently a way to natively disable the use of _msearch. If you are having some of the queries timing out I would suggest looking into the performance of the Elasticsearch cluster itself.


(Thomas Decaux) #3

ok got it, the response size is 50Mo !!! Woa, this is because Kibana loads all pages in one shot :confused: and we have big documents (2 discover widgets in dashboard, was causing the huge response size).

I am thinking the dashboard like a web page, I cannot imaging a web page loading ALL resources (CSS/JS/IMG) in one time, isnit (or via HTTP/2.0) ?

Also, load widget separately could help for caching, or even to load other data source (yeah!).

Thanks you,


(Thomas Decaux) #4

Hmm

I am not 100% sure, but Kibana is using gzip with elasticsearch ?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.