Disable instrumentation for event target not working in apm-rum

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

TIP 1: select at least one tag that further categorizes your topic. For example server for APM Server related questions, java for questions regarding the Elastic APM Java agent, or ui for questions about the APM App within Kibana.

TIP 2: Check out the troubleshooting guide first. Not only will it help you to resolve common problems faster but it also explains in more detail which information we need before we can properly help you.

Kibana version:7.9

Elasticsearch version:7.9

APM Server version:7.9

APM Agent language and version:apm-rum and apm-rum-core

Browser version:

Original install method (e.g. download page, yum, deb, from source, etc.) and version:

Fresh install or upgraded from other version?

I am trying to use the apm-rum/apm-rum-core packages in my angular application.The index.d.ts is missing the InstrumentationTypes 'eventtarget' so not able to disable the default instrumentation for the same.
Is there any reason for this or its a bug.
rejitha Raj

Hi @rejitha1,

The RUM agent already supports disabling eventtarget instrumentation, Its just the typings that is not updated which is already being fixed in this PR - https://github.com/elastic/apm-agent-rum-js/pull/920

But you can disable it using the disableInstrumentations config - https://www.elastic.co/guide/en/apm/agent/rum-js/current/configuration.html#disable-instrumentations

  disableInstrumentations: ['eventtarget']


Thanks for the quick response. I tried the same but getting typescript compile error. Is the fix part of the released version of rum package.
Rejitha Raj

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.