Disabling _source but still seeing the results on query


(Catalin Constantin) #1

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(vineeth mohan) #2

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin dazoot@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(Catalin Constantin) #3

Each field in the mapping has store: "no".

"email": {"type": "string", "indexed": "analyzed", "store": "no",
"boost": 1 },

I can still see "email" in the search results.

Any other hints ?

joi, 10 mai 2012, 12:26:58 UTC+3, Vineeth Mohan a scris:

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin dazoot@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(Andrew[.:at:.]DataFeedFile.com) #4

Where do you see 'email' in the result?
In the _source section of each result?
Can you paste your query and result here.

--Andrew

On May 10, 4:38 am, Catalin Constantin daz...@gmail.com wrote:

Each field in the mapping has store: "no".

"email": {"type": "string", "indexed": "analyzed", "store": "no",
"boost": 1 },

I can still see "email" in the search results.

Any other hints ?

joi, 10 mai 2012, 12:26:58 UTC+3, Vineeth Mohan a scris:

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin daz...@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(Jérémie BORDIER) #5

If you're seeing that when doing a "Get" query, it's because the
document is fetched from the transaction log, it's a bug solved in the
master branch that will be rolled out in 0.19.4.

Jérémie

On Thu, May 10, 2012 at 4:52 PM, Andrew[.:at:.]DataFeedFile.com
andrew@datafeedfile.com wrote:

Where do you see 'email' in the result?
In the _source section of each result?
Can you paste your query and result here.

--Andrew

On May 10, 4:38 am, Catalin Constantin daz...@gmail.com wrote:

Each field in the mapping has store: "no".

"email": {"type": "string", "indexed": "analyzed", "store": "no",
"boost": 1 },

I can still see "email" in the search results.

Any other hints ?

joi, 10 mai 2012, 12:26:58 UTC+3, Vineeth Mohan a scris:

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin daz...@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!

--
Jérémie 'ahFeel' BORDIER


(Shay Banon) #6

Just to correct this answer (sorry Vineeh), ES doesn't keep 3 copies of the
data by default. By default, it keeps only one copy, which is the full json
document stored. The default "store" for specific fields is false, and most
times, should not be set to true (unless you really want to store that
field separately as well).

On Thu, May 10, 2012 at 12:26 PM, Vineeth Mohan
vineethmohan@algotree.comwrote:

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin dazoot@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and _index.enabled to False like this:
esconn.create_index(index_name, {"_source": {"enabled": False}, "_index":
{"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(Shay Banon) #7
  • Can you do a get mapping and see if the mapping you set are actually set?
  • Verifying: you say you get the _source when searching, right?

On Thu, May 10, 2012 at 12:38 PM, Catalin Constantin dazoot@gmail.comwrote:

Each field in the mapping has store: "no".

"email": {"type": "string", "indexed": "analyzed", "store": "no",
"boost": 1 },

I can still see "email" in the search results.

Any other hints ?

joi, 10 mai 2012, 12:26:58 UTC+3, Vineeth Mohan a scris:

try adding
store to false for each field.

In my understanding ES , keep 3 copy of each fields , one in _source ,
other in _all and other as store.

Thanks
Vineeth

On Thu, May 10, 2012 at 2:38 PM, Catalin Constantin dazoot@gmail.comwrote:

Hello. I'm using pyes (python client) and when creating an index, i set
_source.enabled to False and index.enabled to False like this:
esconn.create_index(index
**name, {"_source": {"enabled": False},
"_index": {"enabled": False}, "include_in_all": False})
I still get the _source parameter filled in the query results.

What do i do wrong ?

Thank you!


(system) #8