Discover page not working


(Benjamin Gathmann) #1

Hi there,

I am using Kibana (Version 4.3.1) for the first time.
I have an index with very large documents (5-15MB original size) and about 1300 fields (deep-nested structure). It has no timestamp field (so I un-ticked the respective box when adding the index).

I can create aggregations in the "Visualization" page, but when I try to use the "Discover" page, it displays "Searching" and nothing else, and then the page becomes unresponsive. The Search box shows the *.
A couple of times I have been able to enter some search term in the box, but then the page responded that it did not find any results.
In particular, the left panel "Selected fields" and "Available fields" does not show anything.

I suspect that the size of the documents is the problem here, because Kibana tries to load the complete _source (?). I noticed that I have free RAM left, but the CPU is at 100% most of the time.

Anybody has an idea what could be wrong and what I can do?
E.g. prevent Kibana to load the complete _source?


(Lee Drengenberg) #2

Hi Benjamin,

If you're right and the problem is the document size, you could try going to Settings > Advanced and set discover:sampleSize to a smaller size and see what happens.

Lee


(Benjamin Gathmann) #3

Hi Lee,
I have tried this already, set it to 1, but no luck.
Yours,Benjamin

Am Dienstag, 12. Januar 2016 schrieb Lee Drengenberg :


(Benjamin Gathmann) #4

Hi there, surprise, surprise:
The Discover page does work in Firefox, even with many results (discover:sampleSize=100)!
I tried on Chrome yesterday, but there it will not work (i.e. the behavior I reported above).
Versions I am using:
Firefox: 43.0.4 (32 bit)
Chrome: 47.0.2526.106 m


(Benjamin Gathmann) #5

Some more info:
If I set discover:sampleSize=1 and load the Discovery page with the default *, I get a result. I can then select some of the available fields and run a query. I can then also set discover:sampleSize=100 and run the query again, so it gives me a table with results and the requested fields.
However, if I set discover:sampleSize=100 from the beginning, Firefox will also load the Discover page "forever", with CPU at 100%.
IMHO, the problem is that the Discover page loads the complete _source for the documents by default. It should somehow be possible to set a different default (e.g. load no _source at all).


(Lee Drengenberg) #6

Hi Benjamin,

I see in the request for the Discover tab it has;

"fields": [
    "*",
    "_source"
  ],

I don't think there's any way you can currently change that behavior (other than changing the code). Can you create a github issue here https://github.com/elastic/kibana/issues asking for a setting to turn off the _source part of that?

Thanks,
Lee


(Benjamin Gathmann) #7

Ok, done!


(Benjamin Gathmann) #8

(system) #9