Issue with Kibana Discover page not showing results


(Bill Youngman) #1

I have an intermittent issue with the Discover page not showing any results even though when I do a search through the 'Dev' area I get a several hits on what I am trying to search for. I've tried the suggestions in the various forums to no avail and what I end up having to do is restart both the ElasticSearch and Kibana services to clear the problem.

Does anyone know what might be causing my issue and what I can do to resolve it because this is a production system and I can't keep having to do this whenever this problem occurs.

I'm on the version 5.3.3 framework.

TIA,
Bill Youngman


(Lukas Olson) #2

On Discover, click on the icon under the chart:

Then, in the drop-down, select "Request", and copy the request body, and try sending that to Elasticsearch. Perhaps that can help you figure out why there are no results.


(Bill Youngman) #3

Tried your suggestion and the results that it returned matched what I was seeing on the Discover page which I think is to be expected; however, I may have stumbled onto another larger issue.

It seems that when this happens I will see an entry in the ElasticSearch log notifying that ElasticSearch failed to load started shards. Following the stack trace will take me to a java.nio.file.NoSuchFileException message: (e.g. D:\ELK\elasticsearch-5.2.2\data\nodes\0\indices\9CZWTDyMTFShsnRIDBdQfQ_state\state-40.st).

When I navigate to the directory location on the server I see instead a file state-52.st.

Restarting both the Logstash as well as the ElasticSearch services appears to synch everything back up and then I start seeing results in the Kibana Discover page. What could be causing this behavior?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.