Diskio Fields Are Not available To Create Visualization


(Prakher Singhal) #1

Hello,

Greetings to all community members.

I need a little help here. When I am trying to create a diskio visualization, the fields like system.diskio.read.count, system.diskio.write.count, and other system.diskio.xx.xx fields aren't available to choose from the drop down list.

These fields are available for querying on Kibana Discover as well as on TimeLion but not available to create visualization. Is there any particular reason that diskio fields aren't available there?

Elasticsearch version: 5.2.1
Metricbeat version: 5.2.2
OS: Windows

Thanks.


(CJ Cenizal) #2

Hi there, I'm sorry I'm not familiar with Diskio, but I can tell you that a field needs to be marked as aggregatable and searchable to be used in a visualization. Here are a couple previous posts in which users solved this problem:

Could you take a look and let me know if they help?

Thanks,
CJ


(Prakher Singhal) #3

Hi @cjcenizal

Those links help in fixing it. This is exactly what I tried:

I have refreshed the metricbeat fields and I could see the diskio fields are searchable and aggregatable now.

I have also learned some useful GET queries which can tell us if the fields are mapped and are searchable and aggregatable or not.

GET metricbeat*/_mapping/metricsets/field/system.diskio.read.count

and

GET /_field_stats?fields=system.diskio.read.count


(CJ Cenizal) #4

Great! I'm glad you were able to solve your problem. Thanks for posting, Prakher.

CJ


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.