Document and field level security not supported in trial license

I have just made a trial installation of the Elastic Cloud to test out document level security. But when I configure document level security via the Elasticsearch API I get an error message saying that "Document and field level security is not supported in this license".
Why does the trial deployment have these license limitations? How can I evaluate the feature then?

What is the output from GET /_license?

What did you install exactly?
What people typically mean when they refer to Elastic Cloud is our hosted solution, but that doesn't require installation.

1 Like

Output from GET _license

{
   "license" : {
     "status" : "active",
     "uid" : "fb7a9815-8b0a-4608-b786-049fbec4a4a8",
     "type" : "platinum",
     "issue_date" : "2020-03-24T00:00:00.000Z",
     "issue_date_in_millis" : 1585008000000,
     "expiry_date" : "2022-06-30T00:00:00.000Z",
     "expiry_date_in_millis" : 1656547200000,
     "max_nodes" : 100000,
     "issued_to" : "Elastic Cloud",
     "issuer" : "API",
     "start_date_in_millis" : 1614556800000
   }
}

It looks like you have a platinum license and the subscriptions page indicates field and document level security should be available at that level so it should work.

@boskjoett please don't post things like your Cloud ID, as it will let other people connect to your Elasticsearch cluster. I've delete the post that contained this info.

1 Like

On the elastic.co web site I clicked "Start a free trial", so I have a trial deployment of the Elastic stack.

I tried setting up a role with document level security using Postman, and it worked. So it works. I will close this issue.