Does Elasticsearch 7.11 not supported by ECK operator

Hi,

I trying to deploy the Elasticsearch 7.11.0 version cluster using eck operator 1.3 version, it fails in init container elastic-internal-init-filesystem . It says unsupported_distribution

Is 7.11 version not supported by ECK operator ?

What is exactly your configuration?

Hi @dadoonet ,

Below is my cluster config file.

apiVersion: elasticsearch.k8s.elastic.co/v1
kind: Elasticsearch
metadata:
name: elasticsearch-sample
spec:
version: 7.11.2
nodeSets:
- name: master
count: 3
config:
node.master: true
node.data: false
node.ingest: false
cluster.remote.connect: false
http.compression: true
http.cors.enabled: true
http.cors.allow-origin: ""
node.ml: false
xpack.ml.enabled: false
podTemplate:
metadata:
labels:
elastic-cluster: "true"
spec:
imagePullSecrets:
- name: registrykey
initContainers:
- name: sysctl
securityContext:
privileged: true
command: ['sh', '-c', 'sysctl -w vm.max_map_count=262144']
containers:
- name: elasticsearch
resources:
requests:
memory: 4Gi
cpu: 1
limits:
memory: 4Gi
cpu: 1
env:
- name: ES_JAVA_OPTS
value: "-Xms2g -Xmx2g"
volumeClaimTemplates:
- metadata:
name: elasticsearch-data
spec:
accessModes:
- ReadWriteOnce
resources:
requests:
storage: 10Gi
storageClassName: elasticsearch-storageclass
- name: data
count: 2
config:
node.master: false
node.data: true
node.ingest: true
cluster.remote.connect: false
http.compression: true
http.cors.enabled: true
http.cors.allow-origin: "
"
node.ml: false
xpack.ml.enabled: false
podTemplate:
metadata:
labels:
elastic-cluster: "true"
spec:
imagePullSecrets:
- name: registrykey
initContainers:
- name: sysctl
securityContext:
privileged: true
command: ['sh', '-c', 'sysctl -w vm.max_map_count=262144']
containers:
- name: elasticsearch
resources:
resources:
memory: 8Gi
cpu: 2
limits:
memory: 8Gi
cpu: 2
env:
- name: ES_JAVA_OPTS
value: "-Xms4g -Xmx4g"
volumeClaimTemplates:
- metadata:
name: elasticsearch-data
spec:
accessModes:
- ReadWriteOnce
resources:
requests:
storage: 10Gi
storageClassName: elasticsearch-storageclass
http:
tls:
selfSignedCertificate:
disabled: true

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.