Does not take the timezone of dateFormat: tz in kibana

Hello everyone,
I am having a problem in the axes of my timelion since the timezone of Brazil was changed, I have already adjusted the global configuration in kibana and resolved to the discovery, but for the timelion no, it always stays one hour ahead. Could someone please help me? thankful.


Hey @Diego_Nogueira1, what version of Kibana are you using? Also, would you mind sharing your Timelion query?

@Brandon_Kobel, Tks for reply.

My kibana Version: 6.4.2

My Query:

.es(exists:service).if(eq, 0, null, .es(index=data-channels-, q="service:M2B", timefield=@timestamp, metric=sum:busy)).fit(average).label('Ocupado').lines(fill=3,width=0.9).title('Utilização de canais / 5min - M2B').color(#89CFF0).legend(columns=2, position=sw,showTime=false), .es(exists:service).if(eq, 0, null, .es(index=data-channels-, q="service:M2B", timefield=@timestamp, metric=sum:busy)).label(null).points(symbol=circle,fill=10,radius=1).color(blue), .static(180, label='Capacidade').color(red)

Best & Regards.

Hey @Diego_Nogueira1, I'm having trouble replicating what you're seeing with 6.4.2. Would you mind seeing if you're experiencing this same issue with this timelion query: .es(index=data-channels-, q="service:M2B", timefield=@timestamp, metric=sum:busy)

Also, are you using the Auto date interval, or are you using a specific interval? Also, what time range are you using?


I have replicated the query you sent but the same problem occurs, only data appears when I change to "4 hours ago".

I also noticed that the discovery has the same problem, contrary to what I said, whenever I enter "15 minutes ago" or "1 hour ago" no data is presented, Both machine and jvm timezone are ok.


Is it just the "Last 4 Hours" option that is causing this? Also, would you mind seeing if you have the same issue when creating a non-Timelion vertical bar chart using the date histogram aggregation?


No problem, I'll check what you asked for!

Do you take this time zone from the local machine? Is there any file? I can suddenly do a test by changing the kibana's timezone file.

I'll arrange what you asked for and then return.

@Diego_Nogueira1, Kibana's server and the client (with the default Browser) setting use your system timezone.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.