Elastic-agent 7.10.0 install error

I have tried this on a couple different GCP instances with the same error below

ffoti@ep-test-gcp-debian:~$ sudo rpm -vi elastic-agent-7.10.0-x86_64.rpm
sudo: rpm: command not found
ffoti@ep-test-gcp-debian:~$ curl -L -O https://artifacts.elastic.co/downloads/beats/elastic-agent/elastic-agent-7.10.0-amd64.deb
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 90.4M  100 90.4M    0     0  74.7M      0  0:00:01  0:00:01 --:--:-- 74.7M
ffoti@ep-test-gcp-debian:~$ sudo dpkg -i elastic-agent-7.10.0-amd64.deb
Selecting previously unselected package elastic-agent.
(Reading database ... 38712 files and directories currently installed.)
Preparing to unpack elastic-agent-7.10.0-amd64.deb ...
Unpacking elastic-agent (7.10.0) ...
Setting up elastic-agent (7.10.0) ...
Processing triggers for systemd (241-7~deb10u4) ...
ffoti@ep-test-gcp-debian:~$ cd /usr/share/elastic-agent/bin
ffoti@ep-test-gcp-debian:/usr/share/elastic-agent/bin$ sudo ./elastic-agent install -f --kibana-url=https://2fadc60b34cf40479ee0bee875eeaab9.us-east4.gcp.elastic-cloud.com:443 --enrollment-token=Y1ZEN3ZYVUJDM28telBHWEpXZlo6WFlxYWlIRzBSQzZsTU9BNUVVV1oxUQ==
The Elastic Agent is currently in BETA and should not be used in production
Error: failed to discover the source directory for installation: missing elastic-agent
1 Like

I've just run into this in testing on CentOS 7 with the 7.10.0 RPM available here: https://www.elastic.co/downloads/elastic-agent

It appears there is something wrong with the OS specific packages (RPM and DEB). I get the same "missing elastic-agent" error.

I have instead downloaded the tarball for "Linux 64-bit" and ran the "install" command with parameters successfully.

  1. Download https://artifacts.elastic.co/downloads/beats/elastic-agent/elastic-agent-7.10.0-linux-x86_64.tar.gz
  2. Extract tarball
  3. Run sudo ./elastic-agent install -f <rest of parameters> inside the extracted directory.

This issue should be attributed to something faulty in the OS packaging configuration.

Thanks, I ran into it on Centos 8 and Debian as well. both GCP instances. I'll wait a couple more relaease from now and try End Point again then.

sorry for the troubles, I believe we found and fixed this and it is slated for a coming patch release - see Beats pull request: https://github.com/elastic/beats/pull/22543
and issue: https://github.com/elastic/beats/issues/22360

It is not yet built to be tried out but it should be within a few days or so.


When using the RPM to install you need to switch to the enroll command, not the install command. The install command is the recommended way, which does not use the RPM.

If you download the linux *.tar.gz and run install from inside of that directory it will work. If you want to use the RPM, you should switch to: elastic-agent enroll {kibana_url} {enrollment_token}.

Note: The RPM is not the recommended installation method. It will prevent the ability to perform upgrades directly from Kibana.

1 Like

Same goes for DEB, it seems.

@grin Yes, it also applies for DEB.

Both RPM/DEB installations require the usage of enroll command, vs install command.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.