Is the elastic-agent 8.3.3 debian package broken?


last friday I updated all of my elastic agents from 8.3.2 to 8.3.3 and unfortunately this broke my elastic-agent installations on Ubuntu.
I used the debian package from this link in order to make a fresh install, but when calling elastic-agent enroll I still get the same error message:

/usr/bin/elastic-agent: line 6: /usr/share/elastic-agent/bin/elastic-agent: No such file or directory

When looking at the file /usr/share/elastic-agent/bin/elastic-agent I noticed the file points to /usr/share/elastic-agent/elastic-agent-0ffbed/elastic-agent, which does not exist.
Here is the output of ls -l:

lrwxrwxrwx 1 root root 59 Aug 1 16:01 /usr/share/elastic-agent/bin/elastic-agent -> /usr/share/elastic-agent/elastic-agent-0ffbed/elastic-agent

For now I reinstalled version 8.3.2 but i would like to be able to update my elastic-agents to the latest version :slight_smile:
Is there a fix?

Any help will be greatly appreciated!

Hi @hanna Welcome to the community.

Interesting looks like that binary link is not correct.

I pinged the internal team, let's see if they come back with something.

Hiya @hanna Looks like you bumped into a known issue

The workaround for 8.3.3:

The temp fix

$ sudo unlink /usr/share/elastic-agent/bin/elastic-agent
$ sudo ln -s /var/lib/elastic-agent/data/elastic-agent-0ffbed/elastic-agent /usr/share/elastic-agent/bin/elastic-agent
1 Like

Thanks a lot @stephenb ! :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.