Elastic-agent loading default Dashboards

I am upgrading beats to elastic-agents for shipping the logs. How can i load default dashboards using elastic beats. what are the communication port i need to enable to achieve this requirements

In beats yml file this needs to be enable
look for following

setup.dashboards.enabled: true
  host: "kibana_host:5601"
  username: "elastic"
  password: "changeme"

all your dashbaord are located in /usr/share/beats-name/kibana folder.

if you do this it is going to load hundreds of dashbaords and visulizations.
if you only want particular dashboard then you have to do more work and remove unwanted .json files from that dir.

How to do this configurations via elastic-agents ?. i am planning to replace filebeat and instead of this installing elastic-beats (for setting up filebeat,metricbeat,..etc together). i dont want to enable individually . need to enable and manage via elastic-agent

I have no experience with agent. may be someone else can pick up this and answer you

I think that with the Elastic Agent you don't need to load the dashboards, it will be loaded when you enable the integration through Kibana.

There is an old topic with a similar question.

Dashboard is disabled in Datastream.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.