Elastic APM Version Vs elasticsearch Version

Team,

we have an ELK environment with following versions, and we want to have APM on our Infrastrcture.

can I Install 7.8 (or latest) APM and will it be fine to have a APM of 7.8 or 7.9 have a conversation with ELK of 6.8. 0 ?

Kibana version:
6.8.5
Elasticsearch version:
6.8.0
APM Server version:

Hi @mdamera,
APM Server 7.x will not be compatible with ES and Kibana 6.x, you can find details in the compatibility matrix. You might want to install the latest 6.8.x version of the APM Server until you are ready to upgrade your whole stack to 7.x. Most of the latest APM agents are compatible with the 6.8 version of the APM Server, find an overview in APM Agent/Server compatibility.