Elastic doesn't harvesting specifics logs types from specific machines

my team use ELK to control our logs.
We have about 30 different log types, that we are sending both from our grid machines and both from our client side machines.
The client side machines work with filebeat-->logstash-->elastic-->Kibana
From some reason 2 specific types is not appearing in Kibana from the UAT and Prod machines.
but, when i setup my personal machines and copy the filebeat.yml from them it worked perfectly, and also it works fine in the QA machine.
I already tried to do a diff between the configuration files and they are really the same. Also the path and the logs i tried to sent is the same but still it work from only part of the machines.
when i tried to debug the filebeat service over UAT i didnt see an atemmt to harvest this specific logs - but because this machine works with a big amount of paths and logs im not sure if it is a good indication.

my idea is to change the config from:
to :

i didn't find the right syntax to do so. i saw this page:
but rabbitmq is not one of them. is there any way to do so?

i saw this discussion:
that answer my question
you cant sent logs from Filebeat to RabbitMQ

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.