Elastic endpoint Could not communicate with Checking API will retry

Hello everybody,

I am trying elastic endpoint from code source and I am getting this error:

Could not communicate with Checking API will retry, error: fail to checkin to fleet: Post "https://@IP_KIBANA:5601/api/ingest_manager/fleet/agents/**enrollement_key**/checkin?": net/http: request canceled (Client.Timeout exceeded while awaiting headers)

I tried it on windows and Linux and have the same issue
To configure it I run the below commands:

for windows:

.\elastic-agent enroll --certificate-authorities ca.crt https://@ip_KIBANA:5601 @enrollment token
.\install-service-elastic-agent.ps1

and for linux:

elastic-agent enroll --certificate-authorities ca.crt https://@ip_KIBANA:5601 @enrollment token
systemctl enable elastic-agent
systemctl start elastic-agent

I am using elasticsearch and kibana 8.0.0

Im also dealing with the same issue. I can communicate initially but eventually the check command fails and shutdown the elastic agent.

hello @mikemitchell,

For me I found the issue, it was my bad cause I was trying it in a VM and it the network adapter was configured in bridge mode
if it's not the case for you, make sure that your firewall doesn't block your packets

Best regards

@TheHunter1

Thanks for the response.

On my side, the initial connections are succesfully but over time the checkin endpoint fails and stops the services. When I curl the checkin service on the Kibana Fleet endpoint, I get a response stating the service is not found.

I had once the same issue, but even with chekin problems it works for me, after I enrolled the agent I had just to restart the windows machine and then I began receiving endpoint data