Elastic/logstash puppet forge module config_dir not being set

I am working with the following module in puppet forge:

This is my current profile: https://gist.github.com/cgutshal/116d2cfd1bd21b9083088bfbacd1a804

The issue I am running into is that while my pipeline configs are places in /data/logstash/conf/conf.d/ as expected, the other config files are still created in /etc/logstash regardless of if I define it as follows in my profile.

  $base_dir = '/data/logstash'

  file { $base_dir:
    ensure  => 'directory',
    group   => $config['group'],
    owner   => $config['user']

  class { 'logstash':
    config_dir          => "${base_dir}/conf", #THIS ISN'T WORKING

Not sure what I might be doing wrong that isn't causing this to work as documented, and if there is additional info I can provide let me know. Hoping I just missed something simple.

Any help is appreciated.


how are you running logstash?
what's the error you getting?

In my experience, it is better to run with path.settings to see

./bin/logstash --path.settings /data/logstash

Logstash is being ran via a puppet manifest. The issue is not that I am having errors, its that documentation for the puppet module authored by elastic doesn't seem to work as described, unless I am missing something. Setting config_dir to /data/logstash/conf does not work it is still setting it to /etc/logstash/.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.