Elastic Observability Engineer Lab 4.2: No Metrics showing in Inventory

I'm working through the Elastic Observability course, but I've hit a problem with Lab 4.2. I have no metrics showing in Inventory, so can't proceed with the Lab. It has been a couple of weeks since I last worked on the course, so perhaps my environment has not come up properly? I have tried restarting it already, but no joy. Any advice would be appreciated, thanks. Richard

Hi @rcorfield ,

what happens if you try to check Docker metrics dashboards and System logs and metrics from dashboards?


I've also had issues when taking long breaks between lessons. Try rolling the date back a couple of weeks to when you originally set up the agents to see if this gets you the data you need for lab 4.2.

You may also want to check on your Elastic Agents in Fleet to confirm they are still collecting the relevant metrics/logs from lab 2. Consider this an extra credit activity in troubleshooting a broken deployment. :wink:

I also had issues in 4.3 with the RUM js calls being blocked by Firefox since they are non-TLS. If this happens to you then just disable this protection in your browser for the Petclinic site.

Best of luck!

Unfortunately my Lab time expired before I was able to resolve this :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.