Elastic Observability Engineer Lab 4.3 PetClinict-react service map disconnected

Hi, I have all services connected except petclinic-react , in other words:

petclinic-react is disconnected all these are connected properly: petclinic-node, petclinic-java, petclinic-address-finder, mysql, elasticsearch

I have restarted the docker containers and I also checked that the ELASTIC_APM_SERVER_JS_URL matches what shows in the Virtual Machine: Machine info Public DNS (I changed a few numbers below as not sure if that should be exposed here).

When I clicked focus map it says to check I have the right version of the APM agent - I installed @elastic/apm-rum@4.9.0 as per the labs, and also tried @elastic/apm-rum@4.9.1 since npm outdated said to use that version.

Any ideas?

[EDIT: Maybe related: I have never been able to get any response when I click on the link to the petclinic URL from within the lab instructions - instead I need to open the site by clicking the link within the Strigo tab - almost like the browser is blocking the link?]

[root@petclinic-client server]# cat config.js 

var config = {
  apm_server: process.env.ELASTIC_APM_SERVER_URL || 'http://fleet-server:8200',
  apm_server_token: process.env.ELASTIC_APM_SECRET_TOKEN || 'nonprodpwd',
  apm_server_js: process.env.ELASTIC_APM_SERVER_JS_URL || 'http://ec2-12-34-123-45.eu-central-1.compute.amazonaws.com:8200',
  apm_service_name: process.env.ELASTIC_APM_SERVICE_NAME || 'petclinic-node',
  apm_client_service_name: process.env.ELASTIC_APM_CLIENT_SERVICE_NAME || 'petclinic-react',
  apm_service_version: process.env.ELASTIC_APM_SERVICE_VERSION || '1.0.0',
  api_server: process.env.API_SERVER || 'http://petclinic-server:8000',
  api_prefix: process.env.API_PREFIX || '/petclinic/api',
  address_server: process.env.ADDRESS_SERVER || 'http://address-finder:5000',
  distributedTracingOrigins: process.env.DISTRIBUTED_TRACINGS_ORIGINS || 'http://petclinic-client:4000,http://petclinic-server:8000,http://localhost:4000,http://localhost:8080,http://localhost:8081'

module.exports = config;

Hi @AnitaL ,

please try to access Petclinic from your browser and generate some data to see if the service map gets back to normal. It might happen this sometimes due to the way the load generator works.

Regarding the link inside lab instructions, it won't work because it is behind a proxy in Strigo and we are working on a solution to this. For now, the best way to access the Petclinic application is by using your Public DNS with port 4000 in a browser window/tab.



Thank you so much!

I had already tried generating the data which did not solve it. What solved it:

Access the Petclinic application using my Public DNS with port 4000 in the browser tab.

In other words, copying the link from the Virtual Machine info and adding :4000 at the end, eg


My issue: I had been accessing the Petclinic app from the "open in new tab button icon" within the Virtual machine, and the tab had been opening as eg


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.