Elastic Search 6.4.0 log file filling up the with WARNing messages


#1

ELASTICSEARCH_VERSION=6.4.0

[2018-10-04T16:25:14,539][WARN ][o.e.d.s.f.s.DocValueFieldsFetchSubPhase] Doc-value field [@timestamp] is not using a format. The output will change in 7.0 when doc value fields get formatted based on mappings by default. It is recommended to pass [format=use_field_mapping] with the doc value field in order to opt in for the future behaviour and ease the migration to 7.0.

I updated the template for date fields to have format. But I still see those warnings in the logs. The issue is too many warning messages printed in the logs.

"mappings": {
"applog": {
"properties": {
"@timestamp": {"type": "date","format":"yyyy-MM-dd'T'HH:mm:ss.SSSZ"},


Timestamp warnings in elasticsearch logs
(David Turner) #2

I think this is due to https://github.com/elastic/elasticsearch/pull/29639 which adds the format option to searches returning docvalue fields. The warning is there to tell you to be explicit about the format you want to avoid incompatibility with 7.0. To suppress the warnings, add "format": "use_field_mapping" to the searches that are causing them.

https://www.elastic.co/guide/en/elasticsearch/reference/current/search-request-docvalue-fields.html


#3

Ok, got it. How can I specify field mapping on Kibana? I updated the format for the date fields under KIbana Index Pattern but that didn't help.


(David Turner) #4

Sorry, I don't know enough about Kibana to answer that definitively. I suggest you ask in the Kibana forum.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.