Elasticsearch 0.90.0: UnavailableShardsException

Hello everyone,

I am using Elasticsearch 0.90.0. When I am trying to put a json doc in
some index, I am getting an exception named UnavailableShardsException. I
don't have any idea why I am getting this exception. I tried:

curl -v -XPUT "http://localhost:9200/index-15-10-14/type-15-10-14/123" -d

and what I am getting is this:

{"error":"UnavailableShardsException[[index-15-10-14][4] [2] shardIt, [0]
active : Timeout waiting for [1m], request: index
{[index-15-10-14][type-15-10-14][123], source[{}]}]","status":503}

I also tried to change no. of replicas of the index, as follows:

curl -v -XPUT "http://localhost:9200/index-15-10-14/_settings?pretty" -d

  • "index": {*
  • "number_of_replicas": 0*
  • }*
    but, no luck. When I am using elasticsearch-head plugin to view it, it

Please help!

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d045e17e-03ed-4cc7-ab77-da394f06afd0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.