Elasticsearch 0.90 insallation with .rpm and logging


(Srividhya Umashanker) #1

All -

I downloaded the latest ES rpm and installed on centos. When tried running
the script in foreground, i see that the logging is not enabled.

tried both /etc/init.d/elasticsearch -f and /usr/share/elasticsearch/bin/
-f both.

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

Searched for answers in the internet and tried the following as well

I tried adding export ES_CLASSPATH=/etc/elasticsearch/logging.yml
changed patch.conf, path.data in elasticsearch.yml file also

But, Nothing seems to fix the logging problem. Is there an easier solution
to this problem?

-vidhya

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1f074d2c-4972-469e-a5f5-89f326dd7f0b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Srividhya Umashanker) #2

Had to add this to /usr/share/elasticsearch/bin/elasticsearch
So "any" startup of elasticsearch will pickup

ES_JAVA_OPTS="-Des.config=/etc/elasticsearch/elasticsearch.yml
-Des.path.conf=/etc/elasticsearch/ -Des.path.home=/usr/share/elasticsearch
-Des.path.logs=/var/log/elasticsearch -Des.path.data=/var/lib/elasticsearch
-Des.path.work=/tmp/elasticsearch
-Des.path.plugins=/usr/share/elasticsearch/plugins"

Is this a defect in RPM distribution? We do not want to edit anything post
installation. because our installation is automatic using yum.

Should I raise a defect for this?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b39d430-e761-4e73-99c4-6de3a3501dd8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #3

Hey,

this is a result, that all the package files are moved around in the
filesystem instead of having it centrally in one directory, like in the zip
file distribution. Usually the init script takes care of it all and you do
not have to add all those path configurations manually. Any specific reason
you dont use the init script in /etc/init.d/elasticsearch?

--Alex

On Fri, Jan 10, 2014 at 5:53 AM, Srividhya Umashanker <
srividhya.umashanker@gmail.com> wrote:

Had to add this to /usr/share/elasticsearch/bin/elasticsearch
So "any" startup of elasticsearch will pickup

ES_JAVA_OPTS="-Des.config=/etc/elasticsearch/elasticsearch.yml
-Des.path.conf=/etc/elasticsearch/ -Des.path.home=/usr/share/elasticsearch
-Des.path.logs=/var/log/elasticsearch -Des.path.data=/var/lib/elasticsearch
-Des.path.work=/tmp/elasticsearch
-Des.path.plugins=/usr/share/elasticsearch/plugins"

Is this a defect in RPM distribution? We do not want to edit anything
post installation. because our installation is automatic using yum.

Should I raise a defect for this?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b39d430-e761-4e73-99c4-6de3a3501dd8%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM9juSrTVWvY8q%2BkQrGeLowMfDb100Hv_-V5GjOVcU%3DnFw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Srividhya Umashanker) #4

On Thursday, January 9, 2014 10:14:42 PM UTC+5:30, Srividhya Umashanker
wrote:

All -

I downloaded the latest ES rpm and installed on centos. When tried running
the script in foreground, i see that the logging is not enabled.

tried both /etc/init.d/elasticsearch -f and
/usr/share/elasticsearch/bin/ -f both.

log4j:WARN No appenders could be found for logger (node).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
more info.

Searched for answers in the internet and tried the following as well

I tried adding export ES_CLASSPATH=/etc/elasticsearch/logging.yml
changed patch.conf, path.data in elasticsearch.yml file also

But, Nothing seems to fix the logging problem. Is there an easier solution
to this problem?

-vidhya

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5094ac31-5387-48d5-8152-e438aa9c194f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Srividhya Umashanker) #5

Alex -

I wanted to run it in the foreground for some testing. I think the init.d
script runs it as a demon.

-VIdhya

Hey,

this is a result, that all the package files are moved around in the
filesystem instead of having it centrally in one directory, like in the zip
file distribution. Usually the init script takes care of it all and you do
not have to add all those path configurations manually. Any specific reason
you dont use the init script in /etc/init.d/elasticsearch?

--Alex

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/155dd6e1-42a3-462f-92bc-ad87a9cde218%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6