Elasticsearch 1.0.1 on AWS


(Daniel F.) #1

Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed
documentation of Elasticsearch
(http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and
installed latest EC2 plugin. In the log I have seen that the system have
recognized the installed plugin but no ec2 discovery logs appeared. For a
while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the
plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are
welcome.

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f84410f5-ec3e-4fb8-854e-ff45aefe7ad9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

cloud-aws 2.0.0.RC1 is supposed to work with es 1.0.1.
A new version will come really soon when we will have merged a pending PR.

If you want to make sure that everything is running correctly, you could change logging.yml file and set discovery to TRACE

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 16:12:27, Daniel F. (feinsteindl@gmail.com) a écrit:

Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed documentation of Elasticsearch (http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and installed latest EC2 plugin. In the log I have seen that the system have recognized the installed plugin but no ec2 discovery logs appeared. For a while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are welcome.

Thanks,

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f84410f5-ec3e-4fb8-854e-ff45aefe7ad9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5329b5bb.8f2b15e.97ca%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Daniel F.) #3

Thanks David,

This is the plugin version I use. In plugins/cloud-aws/ I have
elasticsearch-cloud-aws-2.0.0.RC1.jar.

The log level is set to TRACE in logging.yml:

discovery

discovery: TRACE

elasticsearch.yml settings:
discovery.zen.ping.multicast.enabled: false
cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1a
discovery:
type: ec2
groups: my-security-group

The log for all discovery records is:
[2014-03-19 15:45:12,398][DEBUG][discovery.zen.ping.unicast] [Annie
Ghazikhanian] using initial hosts [], with concurrent_connects [10]
[2014-03-19 15:45:12,399][DEBUG][discovery.zen ] [Annie
Ghazikhanian] using ping.timeout [3s], master_election.filter_client
[true], master_election.filter_data [false]
[2014-03-19 15:45:12,400][DEBUG][discovery.zen.elect ] [Annie
Ghazikhanian] using minimum_master_nodes [1]
[2014-03-19 15:45:12,401][DEBUG][discovery.zen.fd ] [Annie
Ghazikhanian] [master] uses ping_interval [1s], ping_timeout [30s],
ping_retries [3]
[2014-03-19 15:45:12,420][DEBUG][discovery.zen.fd ] [Annie
Ghazikhanian] [node ] uses ping_interval [1s], ping_timeout [30s],
ping_retries [3]
[2014-03-19 15:45:14,186][TRACE][discovery ] [Annie
Ghazikhanian] waiting for 30s for the initial state to be set by the
discovery
[2014-03-19 15:45:17,191][TRACE][discovery.zen ] [Annie
Ghazikhanian] full ping responses: {none}
[2014-03-19 15:45:17,191][DEBUG][discovery.zen ] [Annie
Ghazikhanian] filtered ping responses: (filter_client[true],
filter_data[false]) {none}
[2014-03-19 15:45:17,223][TRACE][discovery ] [Annie
Ghazikhanian] initial state set from discovery
[2014-03-19 15:45:17,266][INFO ][discovery ] [Annie
Ghazikhanian] toluna-es-test-cluster-eu/1UlTwLC9TsOfg_Mky1G3Cw

As you could see there are no ec2 discovery records in the log. What do I
miss?

On Wednesday, March 19, 2014 5:20:27 PM UTC+2, David Pilato wrote:

cloud-aws 2.0.0.RC1 is supposed to work with es 1.0.1.
A new version will come really soon when we will have merged a pending PR.

If you want to make sure that everything is running correctly, you could
change logging.yml file and set discovery to TRACE

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 16:12:27, Daniel F. (feins...@gmail.com <javascript:>)
a écrit:

Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed
documentation of Elasticsearch (
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and
installed latest EC2 plugin. In the log I have seen that the system have
recognized the installed plugin but no ec2 discovery logs appeared. For a
while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the
plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are
welcome.

Thanks,

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f84410f5-ec3e-4fb8-854e-ff45aefe7ad9%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/f84410f5-ec3e-4fb8-854e-ff45aefe7ad9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d28f7292-b0ff-4207-8a35-15fba7a595b8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Daniel F.) #4

Thanks David,

This is the plugin version I use. In plugins/cloud-aws/ I have
elasticsearch-cloud-aws-2.0.0.RC1.jar.

The log level is set to TRACE in logging.yml:

discovery

discovery: TRACE

elasticsearch.yml settings:
discovery.zen.ping.multicast.enabled: false
cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1a
discovery:
type: ec2
groups: my-security-group

The log for all discovery records is:
[2014-03-19 15:45:12,398][DEBUG][discovery.zen.ping.unicast] [Annie
Ghazikhanian] using initial hosts [], with concurrent_connects [10]
[2014-03-19 15:45:12,399][DEBUG][discovery.zen ] [Annie
Ghazikhanian] using ping.timeout [3s], master_election.filter_client
[true], master_election.filter_data [false]
[2014-03-19 15:45:12,400][DEBUG][discovery.zen.elect ] [Annie
Ghazikhanian] using minimum_master_nodes [1]
[2014-03-19 15:45:12,401][DEBUG][discovery.zen.fd ] [Annie
Ghazikhanian] [master] uses ping_interval [1s], ping_timeout [30s],
ping_retries [3]
[2014-03-19 15:45:12,420][DEBUG][discovery.zen.fd ] [Annie
Ghazikhanian] [node ] uses ping_interval [1s], ping_timeout [30s],
ping_retries [3]
[2014-03-19 15:45:14,186][TRACE][discovery ] [Annie
Ghazikhanian] waiting for 30s for the initial state to be set by the
discovery
[2014-03-19 15:45:17,191][TRACE][discovery.zen ] [Annie
Ghazikhanian] full ping responses: {none}
[2014-03-19 15:45:17,191][DEBUG][discovery.zen ] [Annie
Ghazikhanian] filtered ping responses: (filter_client[true],
filter_data[false]) {none}
[2014-03-19 15:45:17,223][TRACE][discovery ] [Annie
Ghazikhanian] initial state set from discovery
[2014-03-19 15:45:17,266][INFO ][discovery ] [Annie
Ghazikhanian] toluna-es-test-cluster-eu/1UlTwLC9TsOfg_Mky1G3Cw

As you could see there are no ec2 discovery records in the log. What do I
miss?

On Wednesday, March 19, 2014 5:12:23 PM UTC+2, Daniel F. wrote:

Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed
documentation of Elasticsearch (
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and
installed latest EC2 plugin. In the log I have seen that the system have
recognized the installed plugin but no ec2 discovery logs appeared. For a
while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the
plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are
welcome.

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bb6aee32-d324-4d55-81cb-9afde783a3c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #5

In elasticsearch-cloud-aws-2.0.0.RC1.zip file you should find other files.
Your did not download the ZIP file I guess.

May be you add a line break between

discovery.zen.ping.multicast.enabled: false

and

cloud:

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 16:53:26, Daniel F. (feinsteindl@gmail.com) a écrit:

Thanks David,

This is the plugin version I use. In plugins/cloud-aws/ I have elasticsearch-cloud-aws-2.0.0.RC1.jar.

The log level is set to TRACE in logging.yml:

discovery

discovery: TRACE

elasticsearch.yml settings:
discovery.zen.ping.multicast.enabled: false
cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1a
discovery:
type: ec2
groups: my-security-group

The log for all discovery records is:
[2014-03-19 15:45:12,398][DEBUG][discovery.zen.ping.unicast] [Annie Ghazikhanian] using initial hosts [], with concurrent_connects [10]
[2014-03-19 15:45:12,399][DEBUG][discovery.zen ] [Annie Ghazikhanian] using ping.timeout [3s], master_election.filter_client [true], master_election.filter_data [false]
[2014-03-19 15:45:12,400][DEBUG][discovery.zen.elect ] [Annie Ghazikhanian] using minimum_master_nodes [1]
[2014-03-19 15:45:12,401][DEBUG][discovery.zen.fd ] [Annie Ghazikhanian] [master] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2014-03-19 15:45:12,420][DEBUG][discovery.zen.fd ] [Annie Ghazikhanian] [node ] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2014-03-19 15:45:14,186][TRACE][discovery ] [Annie Ghazikhanian] waiting for 30s for the initial state to be set by the discovery
[2014-03-19 15:45:17,191][TRACE][discovery.zen ] [Annie Ghazikhanian] full ping responses: {none}
[2014-03-19 15:45:17,191][DEBUG][discovery.zen ] [Annie Ghazikhanian] filtered ping responses: (filter_client[true], filter_data[false]) {none}
[2014-03-19 15:45:17,223][TRACE][discovery ] [Annie Ghazikhanian] initial state set from discovery
[2014-03-19 15:45:17,266][INFO ][discovery ] [Annie Ghazikhanian] toluna-es-test-cluster-eu/1UlTwLC9TsOfg_Mky1G3Cw

As you could see there are no ec2 discovery records in the log. What do I miss?

On Wednesday, March 19, 2014 5:12:23 PM UTC+2, Daniel F. wrote:
Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed documentation of Elasticsearch (http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and installed latest EC2 plugin. In the log I have seen that the system have recognized the installed plugin but no ec2 discovery logs appeared. For a while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are welcome.

Thanks,

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bb6aee32-d324-4d55-81cb-9afde783a3c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5329c0c6.76272110.97ca%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Daniel F.) #6

Sorry for confusion I have tried to post only relevant information here.
There are many lines between

discovery.zen.ping.multicast.enabled: false

and ec2 discovery configurations.

In the folder plugins/cloud-aws/ I have the following files:
-rw-r--r-- 1 root root 9276981 Mar 9 11:53 aws-java-sdk-1.3.32.jar
-rw-r--r-- 1 root root 58160 Mar 9 11:53 commons-codec-1.4.jar
-rw-r--r-- 1 root root 60686 Mar 9 11:53 commons-logging-1.1.1.jar
-rw-r--r-- 1 root root 45197 Mar 9 11:53
elasticsearch-cloud-aws-2.0.0.RC1.jar
-rw-r--r-- 1 root root 351132 Mar 9 11:53 httpclient-4.1.1.jar
-rw-r--r-- 1 root root 181041 Mar 9 11:53 httpcore-4.1.jar

On Wednesday, March 19, 2014 5:12:23 PM UTC+2, Daniel F. wrote:

Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed
documentation of Elasticsearch (
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and
installed latest EC2 plugin. In the log I have seen that the system have
recognized the installed plugin but no ec2 discovery logs appeared. For a
while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the
plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are
welcome.

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fde9d055-a854-412c-8f76-5c7bafc07cd9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #7

Are you running elasticsearch as root?
May be you should chown -R elasticsearch /plugins

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 17:24:29, Daniel F. (feinsteindl@gmail.com) a écrit:

Sorry for confusion I have tried to post only relevant information here.
There are many lines between

discovery.zen.ping.multicast.enabled: false

and ec2 discovery configurations.

In the folder plugins/cloud-aws/ I have the following files:
-rw-r--r-- 1 root root 9276981 Mar 9 11:53 aws-java-sdk-1.3.32.jar
-rw-r--r-- 1 root root 58160 Mar 9 11:53 commons-codec-1.4.jar
-rw-r--r-- 1 root root 60686 Mar 9 11:53 commons-logging-1.1.1.jar
-rw-r--r-- 1 root root 45197 Mar 9 11:53 elasticsearch-cloud-aws-2.0.0.RC1.jar
-rw-r--r-- 1 root root 351132 Mar 9 11:53 httpclient-4.1.1.jar
-rw-r--r-- 1 root root 181041 Mar 9 11:53 httpcore-4.1.jar

On Wednesday, March 19, 2014 5:12:23 PM UTC+2, Daniel F. wrote:
Hi,

I am testing Elasticsearch version 1.0.1 on AWS. I have followed documentation of Elasticsearch (http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/) and installed latest EC2 plugin. In the log I have seen that the system have recognized the installed plugin but no ec2 discovery logs appeared. For a while I am using unicast discovery but it is really not convenient.

Does somebody know if there is a known problem in the plugin? Does the plugin work with 1.0.1 version of Elasticsearch? Any other suggestions are welcome.

Thanks,

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fde9d055-a854-412c-8f76-5c7bafc07cd9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5329c517.46b7d447.97ca%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Daniel F.) #8

Yes, i am running elasticsearch as root. It is a test environment so I did
not tune it yet.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #9

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feinsteindl@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I did not tune it yet.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5329fc50.5f3534a4.97ca%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Daniel F.) #10

Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery"
and "region" should not be equal to availability zone "eu-west-1a" but "
eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start
actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com <javascript:>)
a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I did
not tune it yet.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d079915d-b1fb-4ca4-8634-3e35ab460d9a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Geet Gangwar) #11

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated for
elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and
other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also the
second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m
able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:

Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery"
and "region" should not be equal to availability zone "eu-west-1a" but "
eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start
actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I
did not tune it yet.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #12

They are sharing same security group name and are deployed in same region?
If unicast does not work using private IP, aws plugin won't work either.

Can you from one node run

curl http://secondnodeip:9200/

Same from second node.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 08:08, Geet Gangwar geetgangwar@gmail.com a écrit :

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated for elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also the second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:
Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery" and "region" should not be equal to availability zone "eu-west-1a" but "eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:
I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I did not tune it yet.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Geet Gangwar) #13

Thanks David for such a quick reply.

I tried you command from one node to second node and got following result.

{
"status" : 503,
"name" : "cleandata-DataNode-1",
"version" : {
"number" : "1.0.1",
"build_hash" : "5c03844e1978e5cc924dab2a423dc63ce881c42b",
"build_timestamp" : "2014-02-25T15:52:53Z",
"build_snapshot" : false,
"lucene_version" : "4.6"
},
"tagline" : "You Know, for Search"
}

Dont know whehter it is correct or something is wrong.

Regards

Geet

On Fri, Mar 21, 2014 at 12:43 PM, David Pilato david@pilato.fr wrote:

They are sharing same security group name and are deployed in same region?
If unicast does not work using private IP, aws plugin won't work either.

Can you from one node run

curl http://secondnodeip:9200/

Same from second node.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 08:08, Geet Gangwar geetgangwar@gmail.com a écrit :

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated for
elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and
other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also
the second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m
able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:

Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery"
and "region" should not be equal to availability zone "eu-west-1a" but "
eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start
actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I
did not tune it yet.

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.frhttps://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.fr?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #14

status is incorrect but I guess it's due to the fact your data node is not a master node and can't find a master.

How did you set unicast?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 21 mars 2014 à 09:33:35, Geet Gangwar (geetgangwar@gmail.com) a écrit:

Thanks David for such a quick reply.

I tried you command from one node to second node and got following result.

{
"status" : 503,
"name" : "cleandata-DataNode-1",
"version" : {
"number" : "1.0.1",
"build_hash" : "5c03844e1978e5cc924dab2a423dc63ce881c42b",
"build_timestamp" : "2014-02-25T15:52:53Z",
"build_snapshot" : false,
"lucene_version" : "4.6"
},
"tagline" : "You Know, for Search"
}

Dont know whehter it is correct or something is wrong.

Regards

Geet

On Fri, Mar 21, 2014 at 12:43 PM, David Pilato david@pilato.fr wrote:
They are sharing same security group name and are deployed in same region?
If unicast does not work using private IP, aws plugin won't work either.

Can you from one node run

curl http://secondnodeip:9200/

Same from second node.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 08:08, Geet Gangwar geetgangwar@gmail.com a écrit :

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated for elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also the second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:
Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery" and "region" should not be equal to availability zone "eu-west-1a" but "eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:
I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start actually.
So, may be some space before cloud.type: ec2 is missing?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so I did not tune it yet.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.fr.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.532bfcac.4353d0cd.c9bd%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Geet Gangwar) #15

I have set private ip of my data node.

discovery.zen.ping.unicast.hosts: ["10.142.181.16"]
and have disabled the multicast

discovery.zen.ping.multicast.enabled: false

Regards

Geet

On Fri, Mar 21, 2014 at 2:17 PM, David Pilato david@pilato.fr wrote:

status is incorrect but I guess it's due to the fact your data node is not
a master node and can't find a master.

How did you set unicast?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 21 mars 2014 à 09:33:35, Geet Gangwar (geetgangwar@gmail.com) a écrit:

Thanks David for such a quick reply.

I tried you command from one node to second node and got following result.

{
"status" : 503,
"name" : "cleandata-DataNode-1",
"version" : {
"number" : "1.0.1",
"build_hash" : "5c03844e1978e5cc924dab2a423dc63ce881c42b",
"build_timestamp" : "2014-02-25T15:52:53Z",
"build_snapshot" : false,
"lucene_version" : "4.6"
},
"tagline" : "You Know, for Search"
}

Dont know whehter it is correct or something is wrong.

Regards

Geet

On Fri, Mar 21, 2014 at 12:43 PM, David Pilato david@pilato.fr wrote:

They are sharing same security group name and are deployed in same
region?
If unicast does not work using private IP, aws plugin won't work either.

Can you from one node run

curl http://secondnodeip:9200/

Same from second node.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 08:08, Geet Gangwar geetgangwar@gmail.com a écrit :

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated for
elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and
other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also
the second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m
able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:

Thanks David,

You are right elasticsearch.yml had two errors: space before "discovery"
and "region" should not be equal to availability zone "eu-west-1a" but "
eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start
actually.
So, may be some space before cloud.type: ec2 is missing?

 --

David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so
I did not tune it yet.

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.frhttps://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.fr?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.532bfcac.4353d0cd.c9bd%40MacBook-Air-de-David.localhttps://groups.google.com/d/msgid/elasticsearch/etPan.532bfcac.4353d0cd.c9bd%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEXePwcVNDYoNQ%3DdA8eTtiq5J6aXLZZtioRN-DE-o8YOR2OBNg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Geet Gangwar) #16

Hi David,

I tried unicast with making my removing the node.master=false. Now any of
my node can become master.

I this case unicast is working but I have to manually do the unicat setting
in both nodes.

I have also installed cloud-aws plugin on both nodes, still no logs are
getting generated for ec2 discovery.

Regards

Geet

On Fri, Mar 21, 2014 at 2:46 PM, Geet Gangwar geetgangwar@gmail.com wrote:

I have set private ip of my data node.

discovery.zen.ping.unicast.hosts: ["10.142.181.16"]
and have disabled the multicast

discovery.zen.ping.multicast.enabled: false

Regards

Geet

On Fri, Mar 21, 2014 at 2:17 PM, David Pilato david@pilato.fr wrote:

status is incorrect but I guess it's due to the fact your data node is
not a master node and can't find a master.

How did you set unicast?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 21 mars 2014 à 09:33:35, Geet Gangwar (geetgangwar@gmail.com) a écrit:

Thanks David for such a quick reply.

I tried you command from one node to second node and got following result.

{
"status" : 503,
"name" : "cleandata-DataNode-1",
"version" : {
"number" : "1.0.1",
"build_hash" : "5c03844e1978e5cc924dab2a423dc63ce881c42b",
"build_timestamp" : "2014-02-25T15:52:53Z",
"build_snapshot" : false,
"lucene_version" : "4.6"
},
"tagline" : "You Know, for Search"
}

Dont know whehter it is correct or something is wrong.

Regards

Geet

On Fri, Mar 21, 2014 at 12:43 PM, David Pilato david@pilato.fr wrote:

They are sharing same security group name and are deployed in same
region?
If unicast does not work using private IP, aws plugin won't work either.

Can you from one node run

curl http://secondnodeip:9200/

Same from second node.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 08:08, Geet Gangwar geetgangwar@gmail.com a écrit :

Hi

I am also facing same issue of no dicovery.ec2 logs getting generated
for elasticsearch 1.0.1 and cloud-aws plugin 2.0.0.RC

I tried the corrected version of setting given:

cloud:
aws:
access_key: XXXXXX
secret_key: XXXXXX
region: ap-southeast-1
discovery:
type: ec2
groups:

Difference is the region.

I have created two nodes(one is master node with node.data = false and
other one is just a data node with node.master = false)

Even when I try for unicast and specify hard coded private ip then also
the second node does not joins the cluster.

I installed head plugin on the master node which is working fine and I m
able to view one node in the browser.

Please guide me on what I am doing wrong.

On Thursday, March 20, 2014 3:51:36 AM UTC+5:30, Daniel F. wrote:

Thanks David,

You are right elasticsearch.yml had two errors: space before
"discovery" and "region" should not be equal to availability zone "
eu-west-1a" but "eu-west-1".

The working version is:

discovery.zen.ping.multicast.enabled: false

cloud:
aws:
access_key: XXXX
secret_key: XXXX
region: eu-west-1
discovery:
type: ec2
groups: my-security-group

Daniel

On Wednesday, March 19, 2014 10:21:36 PM UTC+2, David Pilato wrote:

I think your elasticsearch.yml is incorrect.

Just saying because as far as I can see, ec2 discovery does not start
actually.
So, may be some space before cloud.type: ec2 is missing?

 --

David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 19:31:03, Daniel F. (feins...@gmail.com) a écrit:

Yes, i am running elasticsearch as root. It is a test environment so
I did not tune it yet.

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5f49602f-9db0-4e68-9037-310a87064f1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/5d40ca9c-ea3b-4d21-84a1-3f6ef907a80e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.frhttps://groups.google.com/d/msgid/elasticsearch/E4CABFBD-9F00-4AB0-9CC7-F06D05B52C9F%40pilato.fr?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAEXePwfmAyp9K88ykHUk78C6tyFPDvr9jFXSV%2BWSoJ3_7xDe-Q%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyFXBVFp_oM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.532bfcac.4353d0cd.c9bd%40MacBook-Air-de-David.localhttps://groups.google.com/d/msgid/elasticsearch/etPan.532bfcac.4353d0cd.c9bd%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEXePweAsnd5e5WJZfw0ERR8YRLAYeApgFfSzLABhjccq6VDkw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #17