Elasticsearch 2.1.1 with _type not indexed


(Wq Huang) #1

Hi,

I am using es 2.1.1+kibana 4.3.1, the _type fields is not indexed as kibana shown,thus I can not do search or filter by _type.The official doc says es will index it by default and the _type field is no longer configurable...How can I solve that ?

Here is what kibana shows:

Here is what happened when I tried to configure _type manually:
{"error":{"root_cause":[{"type":"mapper_parsing_exception","reason":"_type is not configurable"}],"type":"mapper_parsing_exception","reason":"Failed to parse mapping [default]: _type is not configurable","caused_by":{"type":"mapper_parsing_exception","reason":"_type is not configurable"}},"status":400}


(David Pilato) #2

If you need to filter a document by type, it means to me that type is an important data for you.
I'd add a type field in my docs then instead of relying on technical metadata fields.


(John Collaros) #3

Hi,

_type is indexed. But it seems because they have removed the ability to configure settings for _type, it also has removed the information from the _mapping API. Kibana relies on this to be able to know if a field is indexed or not.

A workaround is to edit the setting in the .kibana data itself.

There is more info posted here:
https://discuss.elastic.co/t/elasticsearch-2-0-with--type-not-indexed/35244/18?u=johncollaros&source_topic_id=40092

I have updated the kibana issue, and created an issue in elasticsearch issue tracker, both are linked in there.

With the workaround, I have been able to once again filter on _type.
I never bother indexing type separately, there is no need. That is what _type is for, and as the docs tell you, it is indexed and it is required to be indexed for performance reasons.

Hope this helps.


(system) #4