ElasticSearch 2.3.5 and Bitbucket failes to start

I'm attempting to configure Elasticsearch 2.3.5 to work with our Bitbucket Sever install. I'm using this older version because it is the newest version supported by Bitbucket Server. However, trying to configure Elasticsearch to run as a service is not working at all.

I use service install and it seems to install fine. I then use service start and the elasticsearch-service-x64.log file has a message that the data area passed to a system call is too small. The service of course fails to start.

If I just run Elasticsearch on the command line, it runs fine and I can query it using curl.

Bitbucket does require the use of a plugin they call buckler. I have attempted to start the service with this plugin installed and not. It doesn't affect the output.

I've tried searching extensively through this forum for answers and nothing seems to apply.

I have the exact same setup and what I did was do a yum install elasticsearch on a separate machine which then created a service file for me, which I was able to modify and then place it on my prod box in /etc/init.d and then run 'chkconfig elasticsearch on' which then creates all the entries in the rc directories.

My question is on getting buckler to work. ./plugin install -b https://maven.atlassian.com/content/groups/public/com/atlassian/elasticsearch/buckler-plugin/0.2.12/buckler-plugin-0.2.12-2.3.5.zip

gives me the following error
-> Installing from https://maven.atlassian.com/content/groups/public/com/atlassian/elasticsearch/buckler-plugin/0.2.12/buckler-plugin-0.2.12-2.3.5.zip...
Trying https://maven.atlassian.com/content/groups/public/com/atlassian/elasticsearch/buckler-plugin/0.2.12/buckler-plugin-0.2.12-2.3.5.zip ...
Failed: SocketException[Network is unreachable (connect failed)]

ERROR: failed to download out of all possible locations..., use --verbose to get detailed information

If I was to download the plugin onto my machine - I get the following.
image./plugin install -b file:/opt/alm/buckler-plugin-0.2.12-2.3.5.zip-> Installing from file:/opt/alm/buckler-plugin-0.2.12-2.3.5.zip...
Trying file:/opt/alm/buckler-plugin-0.2.12-2.3.5.zip ...
Downloading .DONE
Verifying file:/opt/alm/buckler-plugin-0.2.12-2.3.5.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: java.lang.IllegalStateException: jar hell!
class: com.atlassian.elasticsearch.buckler.AuthTransportService$AuthTransportRequestHandler
jar1: /opt/alm/elasticsearch/lib/buckler-plugin-0.2.12.jar

jar2: /tmp/3274007109552086368/temp_name388592507/buckler-plugin-0.2.12.jar

Did you manually add your jar in elasticsearch lib dir? You are not supposed to modify the lib dir.

That was it alright. I was trying everything to get this working and must have tried putting it there at some point

I'm glad Chris was able to get his issue addressed. I, unfortunately, left out a major key detail to my setup. I apologize for that. My whole setup is on a Windows Server 2012 system. So my issue is with the setup of the windows service.

May be share logs or something that can help to diagnose?

Of course. Don't take my lack of sharing as an unwillingness to do so. I'm not sure how to attach the logs. Let me see if I can figure this out.

I guess I can't attach a log file. So here is the text from the service log file. This is the only file that is written to when trying to start the service.

[2017-10-17 12:22:15] [info] [ 4364] Commons Daemon procrun ( 64-bit) started
[2017-10-17 12:22:15] [info] [ 4364] Starting service 'elasticsearch-service-x64' ...
[2017-10-17 12:22:17] [error] [ 4364] Failed to start 'elasticsearch-service-x64' service
[2017-10-17 12:22:17] [error] [ 4364] The data area passed to a system call is too small.
[2017-10-17 12:22:17] [info] [ 4364] Start service finished.
[2017-10-17 12:22:17] [error] [ 4364] Commons Daemon procrun failed with exit value: 5 (Failed to start service)
[2017-10-17 12:22:17] [error] [ 4364] The data area passed to a system call is too small.

This is from elasticsearch-service-x64.2017-10-17.log. That date is the last time I tried to start the service.

@Martijn_Laarman does this ring a bell? Is that something like memory allocation problem?

It does not, I could dig in next week.

@Kris_Boultbee is elasticsearch configured to memory locking?

I don't know what that means to be honest. Can you tell me where to look to figure that out?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.