Elasticsearch 4.10.4" with kibanna fail


(Kinomakino) #1

First of all thank you.
I have an ES 4.10.4 running fine.
I had a kibana 4.1.11 running and suddenly it stays in "starting".
After much searching, I opted to try a new kibana on another server.
When putting the address of the ES in the yml and start Kibana from scratch, the same thing happens to me, it does not pass the screen of "initiating"
The kibana log does not display any log, so I think the problem may be in Elasticsearch.

Any ideas?

Thank you !!!


(Christian Dahlqvist) #2

There is no ES 4.10.4. If you access the HTTP endpoint on the server, e.g. http://127.0.0.1:9200, the default response should contain the version you are really using.


(Kinomakino) #3

sorry 1.4.5
the other was lucene version


(Christian Dahlqvist) #4

That is a very old version. I would recommend upgrading.

Is Elasticsearch starting up and working properly? Is there anything in the logs? Do you have any data in the cluster? Is the Kibana index getting created?


(Kinomakino) #5

Thanks for the help.
I use this version of ES because it goes inside a framework and I do not control the program a lot.
The ES logs do not say anything error or anything. The application works perfectly.
I deleted the .kibana index and rebooted the kibana server, to see if it creates it, but it does not.
The file kibana.yml is by default, I just changed the address of ES.

Does it sound like I can do something?


(Christian Dahlqvist) #6

What does your Kibana config look like? Have you configured the address of the ES server? Can you reach ES from the host Kibana is running on?


(Kinomakino) #7

Thank you very much for your help sir, I am quite lost and I have done a thousand tests.
I hit you my kibana.yml
And hit the connection to elasticsearch.
Thank you !!!

# Kibana is served by a back end server. This controls which port to use.
port: 5601

# The host to bind the server to.
host: "0.0.0.0"

# The Elasticsearch instance to use for all your queries.
elasticsearch_url: "http://MYIP:9200"

# preserve_elasticsearch_host true will send the hostname specified in `elasticsearch`. If you set it to false,
# then the host you use to connect to *this* Kibana instance will be sent.
elasticsearch_preserve_host: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations
# and dashboards. It will create a new index if it doesn't already exist.
kibana_index: ".kibana"

# If your Elasticsearch is protected with basic auth, this is the user credentials
# used by the Kibana server to perform maintence on the kibana_index at statup. Your Kibana
# users will still need to authenticate with Elasticsearch (which is proxied thorugh
# the Kibana server)
# kibana_elasticsearch_username: user
# kibana_elasticsearch_password: pass

# If your Elasticsearch requires client certificate and key
# kibana_elasticsearch_client_crt: /path/to/your/client.crt
# kibana_elasticsearch_client_key: /path/to/your/client.key

# If you need to provide a CA certificate for your Elasticsarech instance, put
# the path of the pem file here.
# ca: /path/to/your/CA.pem

# The default application to load.
default_app_id: "discover"

# Time in milliseconds to wait for elasticsearch to respond to pings, defaults to
# request_timeout setting
# ping_timeout: 1500

# Time in milliseconds to wait for responses from the back end or elasticsearch.
# This must be > 0
request_timeout: 300000

# Time in milliseconds for Elasticsearch to wait for responses from shards.
# Set to 0 to disable.
shard_timeout: 0

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying
# startup_timeout: 5000

# Set to false to have a complete disregard for the validity of the SSL
# certificate.
verify_ssl: true

# SSL for outgoing requests from the Kibana Server (PEM formatted)
# ssl_key_file: /path/to/your/server.key
# ssl_cert_file: /path/to/your/server.crt

# Set the path to where you would like the process id file to be created.
# pid_file: /var/run/kibana.pid

# If you would like to send the log output to a file you can set the path below.
# This will also turn off the STDOUT log output.
# log_file: ./kibana.log

# A value to use as a XSRF token. This token is sent back to the server on each request
# and required if you want to execute requests from other clients (like curl).
# xsrf_token: ""

# Plugins that are included in the build, and no longer found in the plugins/ folder
bundled_plugin_ids:
 - plugins/dashboard/index
 - plugins/discover/index
 - plugins/doc/index
 - plugins/kibana/index
 - plugins/markdown_vis/index
 - plugins/metric_vis/index
 - plugins/settings/index
 - plugins/table_vis/index
 - plugins/vis_types/index
 - plugins/visualize/index

(Christian Dahlqvist) #8

Please format the config correctly using the available formatting tools. It is very hard to read as it is. There seems to be index information where the Elasticsearch URL is supposed to be. Is this in the actual config?

Are you able to curl the Elasticsearch URL from the host where Kibana is deployed?


(Kinomakino) #9

Thanks a lot !!!

Both servers are visible to each other.
In fact, Kibana was on the same server as Elastic but it stopped working.
Now I use a separate server


(Christian Dahlqvist) #10

Why do you have verify_ssl set to true?


(Kinomakino) #11

By default.
i changed it to false.

No changes. Kibana doesn´t start and doesn´t create index


(Christian Dahlqvist) #12

As far as I can tell it looks OK, but then I have not used that version in a long time as it is quite old. Maybe someone with more recent experience using it may be able to help?


(system) #13

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.