Elasticsearch 5.0 JAVA API 5.0 on JDK 7


(Augustojaba) #1

My system is compiled on JDK 1.7 and I need to use the Elasticsearch 5.0. I want to use the Elasticsearch JAVA API 5.0 on this system and I cannot change the JDK version that my system is compiled though. How can I proceed since that API is compiled on JAVA 1.8 and I got the Unsupported major.minor version 52.0 error?


(David Pilato) #2

The low level REST client is 1.7 compatible.
But it does not provide all builders you have in the older transport client.

You have to upgrade to 1.8 or stay with elasticsearch 2.x


(Augustojaba) #3

Is this one: https://www.elastic.co/guide/en/elasticsearch/client/java-rest/current/index.html ?


(David Pilato) #4

Yes.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.