ES Transport client 5.4 in java 1.7


I am running ES master and data nodes in 1.8. And i have project where i use java client i.e., transport client. But it runs on the java 1.7. I am getting the exception

2017-06-03 00:38:09.151 o.a.s.d.worker [ERROR] Error on initialization of server mk-workerjava.lang.UnsupportedClassVersionError: org/elasticsearch/index/query/QueryBuilder : Unsupported major.minor version 52.0

Is it strict that client also should be in 1.8? or is there a way to use 1.7. Because my project upgrading to 1.8 is a huge and critical task for us and we require it to be in 1.7. Can anybody give suggestions.


Yes. You need to have a supported jvm version

Can't i run the transport client in java 1.7?

You can but only with old elasticsearch versions.
2.4 should work IIRC

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.