Incompatible Low Version

when java client jar use Elasticsearch 6.8.0,Elastic Server use 6.6.1

image

Is there any soluation to resolve this problem?

Please stop posting images here. Post the error message as properly formatted markdown, to make it easier to read.

To cite https://www.elastic.co/guide/en/elasticsearch/client/java-api/7.2/transport-client.html

Note that you have to set the cluster name if you use one different than "elasticsearch":

Have you taken this into account?

Also, if you have the time, please try the RestClient, as the transport client will be deprecated in 7.0.

--Alex