Elasticsearch 5.3.0 not showing up in Yum list

I'm trying to install Elasticsearch 5.3.0 and I can't get the version to show up on my servers. My servers sit on my internal network, so I download the Elastic stack rpms and put them into my own repo.
I execute createrepo, sync my files to the repo web servers.
On my ES servers, I run yum clean all. Then I run yum list and all I see for elasticsearch is 5.2.2.
The other elastic stack components that I do in the same way, Logstash, beats, etc.. , I get the 5.3.0 versions.
My process is sound. But I think there maybe something weird with the Elasticsearch 5.3.0 rpm. Oh, and I ran the sha1 check on it, and it's valid.


Hi Tim,

So you have populated your own repository with our official rpms?

If you install the elasticsearch rpm directly on a host, does it appear to work as expected and install the correct version?
Do you have the ability to use a proxy to get out to our official repository to fetch rpms or is your internal network entirely separate?

I was able to download the rpm and run an install and it worked ok.
The proxy config through yum has always been a pain in the butt. My server team prefers we don't setup yum with proxies. That is what I will probably do, if I can't get this to work.

I have also tried this on a brand new repo with the same results. It's just odd.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.