Elasticsearch YUM Repositories Are Down


(Van) #1

Elasticsearch Community,

The documentation for installing Elasticsearch as an RPM is out of date. Not sure on the status of the YUM repos. I noticed there was ticket(155198) open in Nov, yet was closed with no resolution.

Let me know!

-Van


(Mark Walkom) #2

If you are noticing a problem then providing details on what you are doing and what you are seeing, including commands, their output, and any other logging, is really helpful.


(Van) #3

Thank you for the response. I made an assumption when attempting to access via my web browser over port 443 and I got a 404 Not Found. Therefore I assumed that the yum install would not work. We also attempted to proxy this internally via Artifactory and still received a 404. In an attempt to answer your question above, I attempted to install elasticsearch on my own Fedora machine.

$ sudo dnf install elasticsearch
Elasticsearch repository for 6.x packages       3.2 MB/s | 9.2 MB     00:02    
Last metadata expiration check: 0:00:04 ago on Fri 11 Jan 2019 02:34:05 PM EST.
Dependencies resolved.
================================================================================
 Package             Arch         Version         Repository               Size
================================================================================
Installing:
 elasticsearch       noarch       6.5.4-1         elasticsearch-6.x       108 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 108 M
Installed size: 160 M
Is this ok [y/N]: y
Downloading Packages:
elasticsearch-6.5.4.rpm                          11 MB/s | 108 MB     00:09    
--------------------------------------------------------------------------------
Total                                            11 MB/s | 108 MB     00:09     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Running scriptlet: elasticsearch-6.5.4-1.noarch                           1/1 
Creating elasticsearch group... OK
Creating elasticsearch user... OK

  Installing       : elasticsearch-6.5.4-1.noarch                           1/1 
  Running scriptlet: elasticsearch-6.5.4-1.noarch                           1/1 
### NOT starting on installation, please execute the following statements to configure elasticsearch service to start automatically using systemd
 sudo systemctl daemon-reload
 sudo systemctl enable elasticsearch.service
### You can start elasticsearch service by executing
 sudo systemctl start elasticsearch.service

Created elasticsearch keystore in /etc/elasticsearch

  Verifying        : elasticsearch-6.5.4-1.noarch                           1/1 

Installed:
  elasticsearch-6.5.4-1.noarch                                                  

Complete!

It worked. This is on us and the ticket can be closed.