Elasticsearch 7.0.1 throws error in ML in bootstrap ( Windows 2012 Server)

stack-machine-learning
(Rupa) #1

I have installed ES 7.0.1 on Windows 2012 Server. And i get following error in the logs when trying to start the ES Service. If i disable the "ml pack" via configuration it works, but i want to use ml pack.


[2019-05-17T17:15:27,975][INFO ][o.e.p.PluginsService ] [telemetry1] loaded module [x-pack-watcher]
[2019-05-17T17:15:27,975][INFO ][o.e.p.PluginsService ] [telemetry1] no plugins loaded
[2019-05-17T17:16:27,099][ERROR][o.e.b.Bootstrap ] [telemetry1] Exception
org.elasticsearch.ElasticsearchException: Failed to create native process factories for Machine Learning
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:433) ~[?:?]
at org.elasticsearch.node.Node.lambda$new$9(Node.java:438) ~[elasticsearch-7.0.1.jar:7.0.1]
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:271) ~[?:?]
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654) ~[?:?]
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) ~[?:?]
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474) ~[?:?]
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913) ~[?:?]
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578) ~[?:?]
at org.elasticsearch.node.Node.(Node.java:441) ~[elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.node.Node.(Node.java:251) ~[elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:211) ~[elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) [elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.0.1.jar:7.0.1]
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.0.1.jar:7.0.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.0.1.jar:7.0.1]
Caused by: java.io.FileNotFoundException: \.\pipe\controller_log_3064 (The system cannot find the file specified)


Any solutions?

(rich collier) #2

Hello - the easiest way to debug this is to find and execute controller.exe from a Command prompt:

  • first with --version as a command-line argument (c:\path\to\controller.exe --version)
  • then again without the --version argument

Report what the output is and post back. Thanks!

(Rupa) #3

Thanks Rich..

It gave me error "api-ms-win-crt-runtime-l1-1-0-dll" is missing, so now i am installing the Windows Updates and the 2015 redistributable.

Any other changes i should make ?

Regards,
rupa