Elasticsearch hangs up on startup on ubuntu server 12.04


(abdo) #1

Hi all

I am having a problem running elasticsearch on ubuntu server 12.04. It hangs up on startup, sometimes it say "libsigar-x86-linux.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c ', or link it with '-z noexecstack'." and in other times nothing comes out (just hangs up).

Regards


(Alexander Reelsen) #2

Hey,

your logged message should just be a warning and not affect the startup.
What exactly hangs when you start up elasticsearch? The init script? If so,
can you start elasticsearch manually? Is there anything in the log files?
Are you using the debian package or another distribution?

--Alex

On Wed, Nov 27, 2013 at 7:21 AM, abdo abdo.a2008@gmail.com wrote:

Hi all

I am having a problem running elasticsearch on ubuntu server 12.04. It
hangs
up on startup, sometimes it say "libsigar-x86-linux.so which might have
disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c
', or link it with '-z noexecstack'." and in other times nothing
comes out (just hangs up).

Regards

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/elasticsearch-hangs-up-on-startup-on-ubuntu-server-12-04-tp4045061.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1385533298409-4045061.post%40n3.nabble.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_W%2BAjPHWHPzVTbDKz22-HB7UN_V7LESP4MA%2B0TytkxoA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #3

I'd like to suggest to recompile the Linux libsigar libraries which come
included in ES to suppress the latest JVM HotSpot warnings.

For this I've opened an issue at Sigar's github:

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHK5FDtKBx%2BWNVSP%2B69V8-7%2BMK-57%2By%3DCnRXA-dqc0fqA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4