Elasticsearch help understanding Update by query version conflicts

Hi -

ELastic 7.6.1:

I am adding some new field mappings to my index.
the index is set to "dynamic" : "strict", so after the mappings are added,

I run:

POST index.test/_update_by_query?refresh&conflicts=proceed

to update the indexing to allow searching by new fields as per the docs:


GET _tasks?detailed=true&actions=*byquery

to look at the job status -
The first time I ran the update query, I get many many version conflicts.

At the time, no data is being fed into the cluster. None of the existing records have any data anywhere near the new field mappings.

So, what would produce a version conflict here if we aren't inserting any data ? and just refreshing a new field mapping.

To make it more interesting, if I run the update by query a second time, there are no version conflicts.

Can someone shed some light on whats happening here, and will any of these conflicts mean I cant search by the new fields when new records are inserted? ( i have no data for the new fields on the existing records)

If there are conflicts the first time, why would they disappear the second time?

Thank You

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.