Elasticsearch in docker container keeps enabling xpack even if explicitely disabled

I'm running elasticsearch for local development in a docker container and disabling xpack explicitely, yet, every x days the container locks itself because the xpack license exprires, elastic stops working

I'm disabling xpack through environment variables in my docker-compose.yml as such

  image: docker.elastic.co/elasticsearch/elasticsearch:5.5.2
  # image: elasticsearch:5.2.2
    - http.host=
    - transport.host=
    - xpack.security.enabled=false
    - "$DATADIR/data:/usr/share/elasticsearch/data"
    - "9200:9200"
    - "9300:9300"

still, xpack license kills my container

51 PM

this is super annoying, how can I get rid of xpack all together?

I have moved your question to the x-pack forum.

Turning off security is not the same as disabling X-Pack. If you have the x-pack plugin installed, then you need to have some form of licence.
The 5.5 docker image ships with X-Pack.

The easiest option is to go to https://register.elastic.co/ and obtain a 12 month licence for X-Pack basic (which is free).

Alternatively you can uninstall X-Pack with theelasticsearch-plugin command, although modifying the container might not be something that you want to do.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.