ElasticSearch Index Wrong Date


(Eric Luellen) #1

Hello,

I recently setup my elasticsearch instance and everything has been working
fine. However, when I looked at Kibana today I saw that the logs stopped
showing up as soon as 2014 hit. When looking at my data on the cluster, I
see this:

ls -altr data/my-cluster/nodes/0/indices/
total 44
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 20 09:39 kibana-int
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 25 14:00
logstash-2013.12.26
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 26 14:00
logstash-2013.12.27
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 27 14:00
logstash-2013.12.28
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 28 14:00
logstash-2013.12.29
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 29 14:00
logstash-2013.12.30
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 30 14:00
logstash-2013.12.31
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 31 14:00
logstash-2013.01.01
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 31 14:00
logstash-2014.01.01
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Jan 1 14:00
logstash-2013.01.02

As you can see, there is one 2014 file and 2 2013 files for the new year
that shouldn't be there. For some reason, elasticsearch thinks it's 2013
still and creating folders with the wrong date. I confirmed that all of my
servers have the correct time on them. How can I fix this on
elasticsearch's end?

Thanks,
Eric

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4d2ed1eb-e7b4-4c51-8b14-15e065d05592%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Eric Luellen) #2

Not sure what happened, but after restarting Logstash everything is working
fine. I guess it just wasn't a fan of the change in year.

On Thursday, January 2, 2014 10:03:05 AM UTC-5, Eric Luellen wrote:

Hello,

I recently setup my elasticsearch instance and everything has been working
fine. However, when I looked at Kibana today I saw that the logs stopped
showing up as soon as 2014 hit. When looking at my data on the cluster, I
see this:

ls -altr data/my-cluster/nodes/0/indices/
total 44
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 20 09:39 kibana-int
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 25 14:00
logstash-2013.12.26
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 26 14:00
logstash-2013.12.27
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 27 14:00
logstash-2013.12.28
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 28 14:00
logstash-2013.12.29
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 29 14:00
logstash-2013.12.30
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 30 14:00
logstash-2013.12.31
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 31 14:00
logstash-2013.01.01
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Dec 31 14:00
logstash-2014.01.01
drwxr-xr-x 8 elasticsearch elasticsearch 4096 Jan 1 14:00
logstash-2013.01.02

As you can see, there is one 2014 file and 2 2013 files for the new year
that shouldn't be there. For some reason, elasticsearch thinks it's 2013
still and creating folders with the wrong date. I confirmed that all of my
servers have the correct time on them. How can I fix this on
elasticsearch's end?

Thanks,
Eric

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/57c938de-7b7c-471f-afd7-df9c409fda5c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3