Elasticsearch not installing


(Roberto Iglesias) #1

Hi.
Im new here, first topic.
Now i'm trying to install ELK, starting from elasticsearch. I have followed the instructions in https://www.elastic.co/guide/en/elasticsearch/reference/current/_installation.html but the process frezzes in this line:
[2016-09-16 08:44:29,963][INFO ][gateway ] [Edward "Ned" Buckman] recovered [0] indices into cluster_state

Im working in a old notebook running Ubuntu 16.04.
Thanks


#2

open your web browser to: http://localhost:9200/
You should see: status 200. If you see this, then you succesfully installed elasticsearch

In fact it's normal that it freezes. You won't launch elasticsearch like that afterwards.


(Roberto Iglesias) #3

Primarily, sorry about my english.
Now, if i follow these instructions, the process get frezzed. So i tried to run dpkg -l | grep elasticsearch and see if the package was installed. And it wasn't.
By the way, i want to say that i tried installing elasticsearch in other way.
I followed the instructions in https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-repositories.html but this way installs elasticsearch version 1.7.3.

#dpkg -l | grep elasticsearch
ii elasticsearch 1.7.3+dfsg-3
ii libelasticsearch1.7-java 1.7.3+dfsg-3

In this point, i tryed to acced to [SERVERIP]:9200 but the conection was refused.
If i run systemctl status elasticsearch.service, i get that is "active(exited)" and there is a warning:
No java runtime was found.

I hope this helps.
Thanks


#4

I'm useless right now sorry ^^

Check this link: https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-16-04

I hope it'll solve your problem !


(Roberto Iglesias) #5

Ok, i'm checking that.
Thank you so much!


(Mark Walkom) #6

That is not frozen, that is Elasticsearch after it has started up and is waiting to do something.


(Roberto Iglesias) #7

Yes, i realized about that a little late. Thanks.


(system) #8