Localhost:9200 not working after install


(janus barinan) #1

Hi,

I first installed ELK where i got the installer from github on my laptop and its working fine. I then installed it on a windows 2008 r2 server and it by typing in my browser localhost:9200 and localhost:5601 gives me a a webpage cannot be displayed. I checked the services and it's all running.

What could be the problem?


(Mark Walkom) #2

Github or https://www.elastic.co/downloads?

Also we’ve renamed ELK to the Elastic Stack, otherwise beats feels left out :wink:


(janus barinan) #3

Hi @warkolm I got it from https://github.com/gigi81/elk-windows-installer/releases. I like it better because there is no powershell involved. I tried installing individually from elastic.co but I had some struggles so stopped for a few days. The one from github works fine on my laptop but doesn't seem to work on my windows 2008r2. They have the same java installed.


(Mark Walkom) #4

You'd have to ask the author if you want support on that.

However I'd suggest you use our MSI installer from https://www.elastic.co/downloads/elasticsearch


(janus barinan) #5

I already ran a netstat and i see the ports(9200 and 5601) are listening.


(janus barinan) #6

i'll trry the msi installer. how about for logstash and kibana? does it have an msi installer too?


(Mark Walkom) #7

Not at this stage.


(janus barinan) #8

Hi,

I installed elastic search from the site you suggested and im stuck at this stage when installing.

elasticsearch_stuck_install


(Mark Walkom) #9

That's not stuck, that is started and waiting for you to interact.

Open a browser and go to http://localhost:9200.


(janus barinan) #10

I think nothing is happening.


(Mark Walkom) #11

Did you change any settings? Do you have a firewall? What OS are you on exactly?


(janus barinan) #12

What settings? I have windows fw disabled. Im using windows server 2008 R2.


(Mark Walkom) #13

Any settings for Elasticsearch


(janus barinan) #14

nope. just ran the installation.


(system) #15

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.