ElasticSearch not working on IP


(Adwait Joshi) #1

I tried to modify the elasticsearch.yml and set the network.host: 192.168.1.226 which is my local IP and the port to 9200 however when I restart elastic and try to do a GREP I see that its not listening on 9200. When I comment that line out I see that elasticsearch is listening. However I can only CURL to localhost and not the actual IP of the machine.

There is no meaningful errors in the log file to be found. Can someone tell me what might be happening here? Thanks.


(David Pilato) #2

Can you share the full log? Formatted please.


(Adwait Joshi) #3

http://dataseers.us/logs/dataseers.log


(David Pilato) #4

You need to fix that:

[2017-10-19T09:45:24,650][INFO ][o.e.b.BootstrapChecks    ] [wTQM_kd] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-10-19T09:45:24,651][ERROR][o.e.b.Bootstrap          ] [wTQM_kd] node validation exception
[1] bootstrap checks failed
[1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html


(Adwait Joshi) #5

Thanks. I will look into this and let you know what I found.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.