Usage of network.host on 5.4


#1

I am installing 5.4 today and I see the an issue. Port 9200 is active when I set network.host: localhost
But, when I set network.host to an IP, I see curl: (7) Failed to connect to port 9200: Connection refused.

Can someone explain what's going on here? I have installed 5.3 very recently but never faced this issue ?

Please help.


(Daniel Mitterdorfer) #2

Hi @bobby259,

Based on your description it's hard to find out what's going on. By setting network.host to an IP other than localhost, Elasticsearch enables bootstrap checks and refuses to start when these checks fail. So I would check the log file of Elasticsearch and apply the necessary fixes. Also see our docs on bootstrap checks for more details.

Daniel


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.