Unable to create elk cluster due to Node validation error

Hello All,

I am setting up elastic cluster in my environment. I have setup a master node and i want the elastic to run on the IP address of master node in order to get the clustering working . When i add the below lines to my elastic YML file i get the below error
Bound or publising to a non loopback address , enforcing bootstrap check , node validation failed and then my elastic crashes . When i run it on local host it starts fine.

This is my configuration

network.host: my ip address
http.host:my ip address
network.bind_host:ip address

Usually when the elastic starts it by default runs on rather than my ip address

Please someone could help me here for my project

Please read Bootstrap Checks | Elasticsearch Guide [8.10] | Elastic

Hi David ,

Thanks for your response , i tried setting up my elastic.yml in similar manner . This is how the network
network.host: site

i get this error again node validation exception bootstrap check failed .System call filters failed to install

Can you please share the snippet or example of what i am doing wrong david this will be of great help , i have been struggling for 2 weeks now .

But did you read the documentation I linked to?

There's a link to the exact problem you wrote.

It will lead you to: System call filter check | Elasticsearch Guide [8.9] | Elastic

I'm not a sys admin so I can't tell exactly what needs to be done.

Also please provide the full logs so experts could tell more :blush:

Change in log4j2.properties and restart ES. Should have more info in the debug mode.

rootLogger.level = debug

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.