Elasticsearch reports wrong version after upgrading from 5.6.x to 6.x


Before updating my production server from 5.6.5 to 6.x I've tried updating my test cluster, but my cluster entered some weird state.

So I have a cluster where are two PCs with elasticsearch 5.6.5 installed from deb repository.

I've upgraded it to version 6.2.3 from the repository and dpkg confirms it:

user@whitebox:~$ sudo dpkg -l | grep elasticsearch
ii  elasticsearch                         6.2.3                                      all

elasticsearch itself reports the new version too:

root@whitebox:/usr/share/elasticsearch/bin# ./elasticsearch --version
Version: 6.2.3, Build: c59ff00/2018-03-13T10:06:29.741383Z, JVM: 1.8.0_151

However, when I make request to IP:9200, it reports old version:

  "name" : "node-whitebox",
  "cluster_name" : "honeypots-dev",
  "cluster_uuid" : "J8Kwgm8cQNamHBGqjazhgw",
  "version" : {
    "number" : "5.6.5",
    "build_hash" : "6a37571",
    "build_date" : "2017-12-04T07:50:10.466Z",
    "build_snapshot" : false,
    "lucene_version" : "6.6.1"
  "tagline" : "You Know, for Search"

Exactly the same thing happened with the second pc. What I'm doing wrong?

ps: Kibana & logstash successfully upgraded to the 6.2.3 version without problems.

Are you sure you don't still have a 5.6.5 node running? Can you retrieve nodes info and look for the version of each node?

It was showing the same - 5.6.5 for both nodes. Eventually, rebooting both PCs solved the issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.