Wrong version of elasticsearch release

Hi,
Im new to elasticSearch but encountered a weird problem (in my opinion).

I download the ES from the website, the version is 5.1.2;
when i run it via the elasticsearch.bat it comes up and when i try to access it it shows me
"
{
"status" : 200,
"name" : "Alchemy",
"cluster_name" : "elasticsearch",
"version" : {
"number" : "1.5.2",
"build_hash" : "62ff9868b4c8a0c45860bebb259e21980778ab1c",
"build_timestamp" : "2015-04-27T09:21:06Z",
"build_snapshot" : false,
"lucene_version" : "4.10.4"
},
"tagline" : "You Know, for Search"
}
"
notice the version is "1.5.2"
looks like a typo in the version ?

now when i try to access kibana it tells me this error
"This version of Kibana requires Elasticsearch v5.1.2 on all nodes. I found the following incompatible nodes in your cluster: v1.5.2"

I installed the ES last week and it worked well with kibana. I wrote a small java example to insert a new index to the ES.
after i tried to run it, this the problem appeared ( im not sure if its connected to the problem but last week i could see a node on kibana)

I tried to change the cluster name and node name ( to make sure my index insert attemp wasnt the cause for the problem) and even after creating new cluster and node the problem still exsits

It is entirly possible that im way off the mark here so ill appreciate any help and suggestions

P.S - if someone has a comeplete example of a simple insert from a java code ill be glad to have it :stuck_out_tongue:

Thanks alot and have a nice day
Sharon Gur.

The force is strong with this one. ES V1.x && Lucene V4.x would denote the wrong executable being used here.

Have a good look around our guides and I would recommend using our latest version (at the time of writing this) https://www.elastic.co/guide/en/elasticsearch/client/java-api/current/java-admin-indices.html

wait, I am using the latest ES version. so you are suggesting my Lucene Version is older? if ill download the latest one my ES wont say 1.5.2?

And ill try the guide you sent Thank you.

I really dont get it.
Checking the ES folder i can see the Lucene JARS in there are version 6.3.0. my ES is version 5.1.2.

Why when i go to "http://localhost:9200"
all the versions are incorrect?

"{
"status" : 200,
"name" : "Alchemy",
"cluster_name" : "elasticsearch",
"version" : {
"number" : "1.5.2",
"build_hash" : "62ff9868b4c8a0c45860bebb259e21980778ab1c",
"build_timestamp" : "2015-04-27T09:21:06Z",
"build_snapshot" : false,
"lucene_version" : "4.10.4"
},
"tagline" : "You Know, for Search"
}"

You probably have an old version of elasticsearch still running on that machine.

1 Like

How can i check it?

if someone along my local net has one running it will be his ES versions i receive?
On my local computer i dont have any ES service running other than the ES 5.1.2 i am running

If you have 2 versions running at the same time, the second usually bind to the next available http port, e.g. 9201. Can you try and see if you find anything on http://localhost:9201 ?

Depends on your OS (Linux/Win), but here we go:

ps -ef | grep elasticsearch

Ok appearntly there was a process running, after killing it my cluster indeed was up and was updated.

Now i cant query my node as i see in the logs

"Received message from unsupported version: [2.0.0] minimal compatible version is: [5.0.0]"
my code is "
"Settings settings = Settings.settingsBuilder()
.put("cluster.name", "sharongur").build();

		Client client = TransportClient.builder().settings(settings).build()
		      .addTransportAddress(new InetSocketTransportAddress(InetAddress.getByName("127.0.0.1"), 9300));
		    
	IndexResponse response = client.prepareIndex("twitter", "tweet", "1")
	        .setSource("{name: blabla}"
	                  )
	        .get();
	
	// Index name
	String _index = response.getIndex();
	// Type name
	String _type = response.getType();
	// Document ID (generated or not)
	String _id = response.getId();
	// Version (if it's the first time you index this document, you will get: 1)
	long _version = response.getVersion();
	
			client.close();"

I checked similiar questions and the answers were that the transportclient is of version 2.0.0, how can i know what transport client i use? is it the version in the dependency in the pom.xml ?

Yes. Read Maven Repository | Java Transport Client (deprecated) [7.15] | Elastic

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.