This version of Kibana requires Elasticsearch v5.4.0


(tomer zaks) #1

Hi,

I did not upgrade the Kibana or ES to 5.4.0 (they are on 5.2.0), but I am getting the following error:

This version of Kibana requires Elasticsearch v5.4.0 on all nodes. I found the following incompatible nodes in your cluster: v5.2.0 @ 192.168.1.114:9200 (192.168.1.114)

How can this be if I didnt upgrade the Kibana?

does this mean every time Kibana has a new version we need to upgrade the ES?


(Brandon Kobel) #2

@tomer Kibana and Elasticsearch versions should be kept in sync, so if you upgrade Kibana to 5.4.0, then Elasticsearch should be upgraded to 5.4.0 as well.

Would you mind verifying the version of Kibana that you're running?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.