elasticsearch.requestTimeout config setting being ignored by visualisations

I'm using Kibana 6.6.0, installed through the official Docker image. The elasticsearch.requestTimeout seems to be being ignored by visualisations. Here is my kibana.yml config:

server.name: kibana
server.host: "0"
elasticsearch.url: http://elasticsearch:9200

server.ssl.key: my_cert.key
server.ssl.certificate: my_cert.crt
server.ssl.enabled: true

elasticsearch.requestTimeout: 60000

No matter what I set this value to though, visualisations seem to timeout at 30000 ms.

If I set a small value like elasticsearch.requestTimeout: 12345 then I can see Timelion complaining about timeouts:
...so it's obviously picked up the config here.

However with this config all other standard visualisations (such as a simple metric visualisation) still seem to keep the default of 30000ms. When I inspect the POST requests going to the _msearch endpoint I see this at the end:

which looks like this config setting is being ignored?

I'm confused! Any pointers on how to debug?

Finally found by reading the source the bit of code that does this, I should have been using:

elasticsearch.shardTimeout: 60000


Glad you figured it out - additionally I was going to make sure you didn't have search.default_search_timeout set in your cluster settings. You can view the current cluster settings from the ES API localhost:9200/_cluster/settings?flat_settings=true

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.