Elasticsearch shield and Kibana 3.x


(Marcello A) #1

Hi All,
we have installed shield on Elasticsearch 1.5 in a test environment. We
have enabled the SSL on http module and the authentication but we noticed
issue on Kibana 3.1.2 version but it's not working.

Did someone configure this plugin and Kibana 3 to works together?

Thanks,
Marcello

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6fe05fda-e941-46c5-9a21-c76e6b188116%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Have you made config changes to KB to deal with the https, as per
http://www.elastic.co/guide/en/shield/current/_shield_with_kibana_3.html

On 27 March 2015 at 00:31, Marcello A cello86@gmail.com wrote:

Hi All,
we have installed shield on Elasticsearch 1.5 in a test environment. We
have enabled the SSL on http module and the authentication but we noticed
issue on Kibana 3.1.2 version but it's not working.

Did someone configure this plugin and Kibana 3 to works together?

Thanks,
Marcello

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6fe05fda-e941-46c5-9a21-c76e6b188116%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6fe05fda-e941-46c5-9a21-c76e6b188116%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8sHA4Q6-j4L0-%2BhYnWH9dZ3D222ubQx4um_3hWm38WNg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Marcello A) #3

Hi Mark,

I have configured the Kibana 3.x in this way:

elasticsearch: {server: "http://elastic01.cello.local:9200",
withCredentials: true},

I put also this configuration on EL side:

http.cors.enabled: true
http.cors.allow-origin: "*"
http.cors.allow-credentials: true

All the configuration works fine with the authentication when I open the
dashboard.

If i activate the SSL on elasticsearch in this way:

shield.http.ssl: true
shield.transport.ssl: true
shield.ssl.protocol: TLS

And i reconfigure Kibana with the HTTPS:

elasticsearch: {server: "https://elastic01.cello.local:9200",
withCredentials: true},

In this way the dashboard doesn't work but if i try to connect directly on
EL with SSL all works fine.

Marcello

Il giorno venerdì 27 marzo 2015 03:46:20 UTC+1, Mark Walkom ha scritto:

Have you made config changes to KB to deal with the https, as per
http://www.elastic.co/guide/en/shield/current/_shield_with_kibana_3.html

On 27 March 2015 at 00:31, Marcello A <cel...@gmail.com <javascript:>>
wrote:

Hi All,
we have installed shield on Elasticsearch 1.5 in a test environment. We
have enabled the SSL on http module and the authentication but we noticed
issue on Kibana 3.1.2 version but it's not working.

Did someone configure this plugin and Kibana 3 to works together?

Thanks,
Marcello

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6fe05fda-e941-46c5-9a21-c76e6b188116%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6fe05fda-e941-46c5-9a21-c76e6b188116%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e050319e-7ce8-4358-af9d-fcd8ee27d3ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#4

Did you get a solution to this?


(system) #5