Elasticsearch: simple cluster. Can't change nodes. Please, help


(Dmitriy Kargapolov) #1

I have a simple cluster with 2 nodes: master/data and data. I need to move
master data to another server. I tried to change master to data and data to
master, also made 3 node master. But always I had one result. Status of
cluster was green and I all shards were 0, but in home directory I had all
data. What should I do to solve this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7f3e78dd-ce57-4509-8b1c-3c8624690bea%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(sirkubax) #2

What this commnad show

curl -XGET 'http://localhost:9200/_nodes/_all/process?pretty=true' |less

W dniu poniedziałek, 9 czerwca 2014 16:41:25 UTC+2 użytkownik Dmitriy
Kargapolov napisał:

I have a simple cluster with 2 nodes: master/data and data. I need to move
master data to another server. I tried to change master to data and data to
master, also made 3 node master. But always I had one result. Status of
cluster was green and I all shards were 0, but in home directory I had all
data. What should I do to solve this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/276abfa2-450a-4e38-b552-faf044651456%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Dmitriy Kargapolov) #3

This command show:

C:\Program Files\Elasticsearch\bin>curl -XGET
"http://localhost:9204/_nodes/_all/process?pretty=true"
{
"ok" : true,
"cluster_name" : "mycluster",
"nodes" : {
"RTlR2GvATs-jqYSRQ5c6bg" : {
"name" : "node4",
"transport_address" : "inet[/192.168.0.89:9304]",
"hostname" : "V04",
"version" : "0.90.12",
"http_address" : "inet[/192.168.0.89:9204]",
"attributes" : {
"master" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 3420,
"max_file_descriptors" : -1,
"mlockall" : false
}
},
"BA2wkXmKTAqQlaULydDjuA" : {
"name" : "node3",
"transport_address" : "inet[/192.168.0.173:9300]",
"hostname" : "V03",
"version" : "0.90.12",
"http_address" : "inet[/192.168.0.173:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 1148,
"max_file_descriptors" : -1,
"mlockall" : false
}
}
}
}

On Mon, Jun 9, 2014 at 5:51 PM, sirkubax jakubxmuszynski@googlemail.com wrote:

What this commnad show

curl -XGET 'http://localhost:9200/_nodes/_all/process?pretty=true' |less

W dniu poniedziałek, 9 czerwca 2014 16:41:25 UTC+2 użytkownik Dmitriy
Kargapolov napisał:

I have a simple cluster with 2 nodes: master/data and data. I need to move
master data to another server. I tried to change master to data and data to
master, also made 3 node master. But always I had one result. Status of
cluster was green and I all shards were 0, but in home directory I had all
data. What should I do to solve this problem?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mBzkcuJq5t0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/276abfa2-450a-4e38-b552-faf044651456%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJBXYCkp9D8%3D555-y-Jb6WoG1o6Y70TfH%2B8fmFbdmOTQ3kAOFg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(sirkubax) #4

Try add "
"data" : "false"
to the node that you would like to remove data (you are trying to move from
node4 -> node3 right?).
I'm not sure, but when operation succeed, data will be copied to node3,
but it as far as I know dhe data will stay on node, To be sure compare
folder size, and if correct, remove them manually.

The setting:
{
"ok" : true,
"cluster_name" : "mycluster",
"nodes" : {
"RTlR2GvATs-jqYSRQ5c6bg" : {
"name" : "node4",
"transport_address" : "inet[/192.168.0.89:9304]",
"hostname" : "V04",
"version" : "0.90.12",
"http_address" : "inet[/192.168.0.89:9204]",
"attributes" : {
"master" : "false"

  •    "data" : "false"*
    }, 
    "process" : { 
      "refresh_interval" : 1000, 
      "id" : 3420, 
      "max_file_descriptors" : -1, 
      "mlockall" : false 
    } 
    
    },
    "BA2wkXmKTAqQlaULydDjuA" : {
    "name" : "node3",
    "transport_address" : "inet[/192.168.0.173:9300]",
    "hostname" : "V03",
    "version" : "0.90.12",
    "http_address" : "inet[/192.168.0.173:9200]",
    "attributes" : {
    "master" : "true"
    },
    "process" : {
    "refresh_interval" : 1000,
    "id" : 1148,
    "max_file_descriptors" : -1,
    "mlockall" : false
    }
    }
    }
    }

Actually

curl localhost:9200/_settings?pretty |less

{
"logstash-2014.05.09" : {
"settings" : {
"index" : {
"uuid" : "D3C5kDoVRUShZbxHsY9i9A",
"analysis" : {
"analyzer" : {
"default" : {
"type" : "standard",
"stopwords" : "none"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"refresh_interval" : "5s",
"version" : {
"created" : "1000199"
}
}
}
},

If you have your replica configured, it should copy to second node itself.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b9828828-7538-47da-a09c-a3cb732607d3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(sirkubax) #5

Try add ""data" : "false"

You can do it in you elasticserh.yml

You can exploit these settings to design advanced cluster topologies.

1. You want this node to never become a master node, only to hold data.

This will be the "workhorse" of your cluster.

node.master: false

node.data: true

2. You want this node to only serve as a master: to not store any data and

to have free resources. This will be the "coordinator" of your cluster.

node.master: true

node.data: false

3. You want this node to be neither master nor data node, but

to act as a "search load balancer" (fetching data from nodes,

aggregating results, etc.)

node.master: false
node.data: false

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dcf61ee3-4589-4841-993a-9f032b4b095c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Dmitriy Kargapolov) #6

Thanks for answering me. But all works now! I made all necessary
operations very slowly and carefully with full restart of servers. And
all work properly. I am really don't understand what the matter was.
Maybe I should to restart some service or process besides
elasticsearch service to make changes. I don't know.

On Tue, Jun 10, 2014 at 11:45 AM, sirkubax
jakubxmuszynski@googlemail.com wrote:

Try add "
"data" : "false"

You can do it in you elasticserh.yml

You can exploit these settings to design advanced cluster topologies.

1. You want this node to never become a master node, only to hold data.

This will be the "workhorse" of your cluster.

node.master: false

node.data: true

2. You want this node to only serve as a master: to not store any data and

to have free resources. This will be the "coordinator" of your cluster.

node.master: true

node.data: false

3. You want this node to be neither master nor data node, but

to act as a "search load balancer" (fetching data from nodes,

aggregating results, etc.)

node.master: false
node.data: false

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mBzkcuJq5t0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dcf61ee3-4589-4841-993a-9f032b4b095c%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJBXYCkpuqwWXgMOe6jzg7yDgSFYe8Whx2xVNp3a3t8Gam%2Bkhg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7