Elasticsearch transport-ware version 1.8.0 -- does not create logstash indices during startup


(Mahesh Venkat) #1

Hi,
I am attempting to run elasticsearch 0.9.10 as a servlet
using elasticsearch transport-ware version 1.8.0.
In this mode, elasticsearch does not create logstash time-based indices.
When I attempt to view the log through Kibana 3, the following calls fails.
I get a 404 error.
http://localhost:9292/logstash-2014.01.28,logstash-2014.01.29,logstash-2014.01.29/_aliases?ignore_missing=true

The same call works when I run elasticsearch as a standlone java app.
As a standalone app I see the following elasticsearch debug messages, which
isn't generated when I run it as a servlet:
[2014-01-28 17:28:35,023][DEBUG][indices ] [allegro] creating Index
[logstash-2014.01.29], shards [5]/[1] [2014-01-28
17:28:35,206][DEBUG][index.mapper ] [allegro] [logstash-2014.01.29] using
dynamic[true], default mapping: default_mapping_location[null],
loaded_from[jar:file:/C:/elasticsearch/elasticsearch-0.90.10/lib/elasticsearch-0.90.10.jar!/org/elasticsearch/index/mapper/default-mapping.json]
[2014-01-28 17:28:35,208][DEBUG][index.cache.query.parser.resident]
[allegro] [logstash-2014.01.29] using [resident] query cache with max_size
[100], expire [null] [2014-01-28 17:28:35,214][DEBUG][index.store.fs ]
[allegro] [logstash-2014.01.29] using index.store.throttle.type [node],
with index.store.throttle.max_bytes_per_sec [0b] [2014-01-28
17:28:35,266][INFO ][cluster.metadata ] [allegro] [logstash-2014.01.29]
creating index, cause [auto(bulk api)], shards [5]/[1], mappings []
[2014-01-28 17:28:35,280][DEBUG][index.cache.filter.weighted] [allegro]
[logstash-2014.01.29] full cache clear, reason [close]

any clues ? Appreciate your help

thanks
--Mahesh

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7621e148-97c5-4882-a665-ad7fa278a5d8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2