Elasticsearch using incorrect user


#1

Hello everyone,
When I run /etc/init.d/elasticsearch start, I am not able to get the correct user
I am not able to set the user "elasticsearch". I set the variable ES_USER but for a strange reason this parameter change to another user. Any ideas?


(Mark Walkom) #2

What does this actually mean? Are you seeing something odd? Did you change something? What version are you on? How did you install ES?

You haven't really given any concrete details about a problem and what you are/aren't seeing.


#3

I am trying to run ES version 2.4

In the file located at /etc/init.d/elasticsearch there is a parameter called "ES_USER"

Run Elasticsearch as this user ID and group ID

ES_USER=elasticsearch
ES_GROUP=elasticsearch

It supossed to be "elasticsearch" by default . but when I run the service I got another user instead of "elasticsearch" and I got problems like permission denied, etc. I dont understand why this user changed.


(Mark Walkom) #4

What user? Where are you seeing this? Can you show us logs?

Please, provide more information or we cannot help.


(system) #5