Elasticsearch V5 is looking for cluster_name folder for data path


(Gayathri TR) #1

Hi Team,

As per: https://www.elastic.co/guide/en/elasticsearch/reference/5.2/_path_to_data_on_disk.html#_local_files

Our elasticsearch was working fine and it was storing index on path: $DATA_DIR/nodes/$nodeOrdinal

But suddenly it's down with the below error:

java.lang.IllegalStateException: failed to obtain node locks, tried [[DATA_DIR/Cluster_E3]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?

It's searching for the cluster named folder, which was not happend before and there are no such folder inside DATA_DIR

Elasticsearch- version 5.0.2

Thanks,

Gayathri


(Simon Willnauer) #2

what you see is just the error message that it tried to use the path with the cluster name since that is how 2.x worked. This is only there for backwards compatibility. Did you maybe still have an ES instance running on that node / datadir?


(Gayathri TR) #3

"No. only one instance is running on that server. And it was working fine before. Suddenly started looking for the old path after a restart..


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.