ElasticSearchParseException when entering indices.fielddata.cache.size in elasticsearch.yml

I am using Elasticsearch 0.90.1. I am attempting to limit the field data
cache size by using the indices.fielddata.cache.size setting. As per the
documentation
at http://www.elasticsearch.org/guide/reference/index-modules/fielddata/ I
should be able to put:

indices.fielddata.cache.size: 10GB

...to set an absolute value limit. When I do this and start elasticsearch,
I get:

  1. ElasticSearchParseException[Failed to parse [10GB]]
    NumberFormatException[For input string: "10GB"]

I have tried wrapping this value in double quotes, which fails with the
same error.

Using a percentage of heap works.

Cheers,
Brad.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You should use
indices.fielddata.cache.size: 10gb

Documentation should be edited, i think, or ByteSizeValue.java in package
org.elasticsearch.common.unit adapted.

Am Freitag, 14. Juni 2013 20:32:54 UTC+2 schrieb Brad Cavanagh:

I am using Elasticsearch 0.90.1. I am attempting to limit the field data
cache size by using the indices.fielddata.cache.size setting. As per the
documentation at
http://www.elasticsearch.org/guide/reference/index-modules/fielddata/ I
should be able to put:

indices.fielddata.cache.size: 10GB

...to set an absolute value limit. When I do this and start elasticsearch,
I get:

  1. ElasticSearchParseException[Failed to parse [10GB]]
    NumberFormatException[For input string: "10GB"]

I have tried wrapping this value in double quotes, which fails with the
same error.

Using a percentage of heap works.

Cheers,
Brad.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.